Octo.exe release notes - escaping?

Octo.exe is being called from Team City, and I am passing through release notes - like this:


Rev. Author When Comment
13021 Darrell.Tunnell 26/05/2015 17:41:18 updated packages.config xml

Which results in the error:
Unrecognized command arguments: border=1, style=width:100%>,

Rev. Author When Comment 13021 Darrell.Tunnell 26/05/2015, 17:41:18 updated, packages.config, xml ,

My question is, as I do not want to have to resort to a release notes file, how do I pass html for the release notes - i.e do I need to apply some escaping / encoding to this argument?

Many Thanks for your help


It seems that the Team City plugin for Octopus Deploy, has a problem preserving quotes around additional command line params.

For example, if in Team City you if you put in the following additional args:

–packagesFolder=“Dist” --deploymenttimeout=“00:12:00” --releasenotes="%system.SvnChangeLog%"

The quotes that are entered are not honoured. The plugin actually ends up invoking Octo.exe without those quotes.

I tried to workaround this problem by not using the Team City plugin, and instead, using a new step (simple command line) to invoke Octo.exe directly - still couldn’t get this to work - I think it might me Team City removing these quotes…

The plugin for Team City is supposed to make things easier, but this unfortunate issue is giving me a headache!

Haven’t managed to find a solution, so going to resort to trying release notes file after all…

Hi Darrell,

Thanks for getting in touch. There does seem to be an issue when TeamCity calls Octo.exe with that html. It works though if you add the HTML to a file and then use the --releasenotesfile parameter. Usually the --releasenotes file alternative is recommended when its needed to pass in so many characters like you are trying to do as release notes.

I’ll discuss this with one of our devs and see what we can do about it.