Octo.exe deploy-release results in warnings

Hello! I’ve started using octo.exe deploy-release to push out releases to production at night instead of clicking the deploy button via the web ui. I’ve got one package whose role is not in production (it’s a back door service for testing). When I deploy via the UI it does not attempt to deploy the package whose role does not exist in production. When I deploy via octo.exe it includes the package in the deployment and then gives a warning during deployment that the role does not exist in the production environment. Is there a way to get octo.exe to behave like the ui?

Thanks!

Hi Jason - I think the best way to achieve this is to go into the project’s deployment process, open the step, and set its Environment targets to just those that it applies in (i.e. Development and Testing). The setting’s near the bottom of the page.

You’ll need to create a new release for this to take effect.

Hope this helps.
Nick

That worked. Thanks!