Octo.exe cannot communicate to Octopus server; certificate errors (exitcode -3)

I’m trying to automate CI builds by creating Octopus releases using the Octo.exe. I’m able to reach the server through a browser over https (only). All commands using Octo.exe return a slew of errors regarding certificates. I’ll see the “handshaking” part of the communication with the octopus server but then numerous errors afterwards. Could not establish trust relationship for the SSL/TLS secure channel, etc. I’ve included a screenshot of the errors that appear.

Ideas on how to resolve this?

Hi Ian,

It looks like the Octopus server is using a self-signed certificate that the machine doesn’t trust - is that correct? If so, you should be able to add the certificate to those trusted by the machine - testing for any cert errors in a web browser should get you to the bottom of it.

Let me know if this helps; if not, a screenshot of IE visiting the Octopus Server, with the certificate properties dialog showing, should help.


I didn’t even consider that as a possibility. I should add a “genuine” certificate on this server but it happens to be our dev/staging, so I figured any cert will do just to get https going. I’ll check this out tomorrow and get back to you asap.

Thanks, Nicholas!

Ok, so our self-signed certificate worked. Once I installed the certificate from the server using Octo.exe into the “Trusted People” folder in the local certificate management withing our server, octo.exe worked like a charm. Thanks, Nick!