Octo.exe can not create-release in version

No matter what API key I use, I can not create a release Octo.exe in version I get the following error …

Error from Octopus server (HTTP 401): You must be logged in to perform this action. Please provide a valid API key or log in again.

  1. I’ve checked my api key,
  2. I’ve created a new api key
  3. I’ve create a new user with a new api key

still can not create a release. The problem first showed up in the team city addin. I then downloaded the octo.exe directly and tried and get the same error.

This is a major blocking issue, should i revert to previous version? How would i revert?

~ Paul

Update, I’ve checked the rest API directly and get the same issue. See screen shot.


What are you executing on the command line? Here is a sample of mine that works perfectly with 2.4.2:

Octo.exe create-release --project=Josh --version --releasenotes=“test” --deployto=Dev --server https://octosrv/api --apiKey “API-{removed}”

My octo.exe version is, server version is

I just reverted the Server install to, now the same api key works. Something is unusual about my install.

Hi - thanks for raising this one. It’s a bug introduced with the new Active Directory groups support. We’re testing 2.4.4 right now with a fix for this included.

Best regards,