NuGet packing unpack incomplete

support

(andrew.laraia) #1

This is a very strange problem that I have not encountered before. I tried rebooting the target machine, and I’ve tried creating new package (new version numbers, etc), and yet during the deployment I’m getting errors that certain files are not found.

When I look at the Octopus\Applications folder I see that the desired files are not there. However, when I look at Octopus<tentacle>\Files\myPackage.version.number.guid.nupkg, which can be opened in any zip utility, you can see that all the files are there.

After I created new packages, to ensure there wasn’t some corrupt package cached somewhere, it failed in a similar way, but on a different file after getting farther along in the process.

Have you ever seen anything like this?


(andrew.laraia) #2

FYI
The path and the file name is greater than 255 characters.
I suspect I need to rename my environment or some of the files and paths to make this all fit.

Count this be the problem?


(Daniel Fischer) #4

Hi Andrew,

Thanks for getting in touch! We have a documentation page which I believe should help you out here.

Let me know if this is what you are after. :slight_smile:

Best regards,
Daniel