NuGet authentication

NuGet 1.5 added support for connecting to private repositories using basic or NTLM authentication. I tried setting up a private NuGet repository on MyGet, but I ran into problems trying to use the NuGet plugin for TeamCity. When NuGet is invoked via the command-line to query a feed that requires authentication, it will prompt for a username as password. I tried to hard-code the username/password in the url (, but NuGet ignores it and still prompts for a username and password. My assumption is that Octopus currently behaves the same way (I haven’t tried yet).

My suggestion is that Octopus should support NuGet repositories that require authentication. I don’t know how important this is to have at this point in time, but it could be handy for people wanting to host private feeds on MyGet or host their own password protected feeds.


Thanks Steven, I’ll look at what it takes to support this over the weekend!


Hi Steven,

You can monitor the progression of this suggestion, and vote for it, on the Trello board: