Not able to login Octopus Web URL from Chrome after upgrading the version from v2018.5.4 to v2019.5.0

(Ramana Rainn) #1

We are currently running Octopus v2018.5.4 version on Windows 2012 R2 server with SQL server 2014 as database.

I’ve followed below steps for upgrading from v2018.5.4 to v2019.5.0.

  1. Took backup of SQL database and Octopus Master Key
  2. Stopped the Octopus Deploy service
  3. Installed v2019.5.0 version on same location where v2018.5.4 was installed and it automatically reconfigured Octopus deploy and service also started successfully.

Now When I tried to login web URL from Chrome and attached error.Octopus - Chrome error.txt (361 Bytes)

But I’m able to login via IE but when I open any project and attached error. Also it doesn’t show any task logs for existing deploys in Octopus.Octopus Project Error.txt (700 Bytes)

Can you please advise if I’m following correct approach for upgrading the Octopus version. Please help us above issues.

(Shannon Lewis) #3

Hi,

Thanks for getting in touch. We’ve had a couple of reports of that isMultiTenancyEnabled error in the UI, it appears to related to files being cached from the previous version in the browser. Could you trying doing a Ctrl-F5 to force a complete reload of the content and see if that issue goes away?

Regarding the error you are seeing in IE, that is a known issue. We have a fix being reviewed for that at the moment, so it shouldn’t be far away.

Sorry for the inconvenience caused.

Regards
Shannon

(Ramana Rainn) #4

Thanks Shannon for quick reply. As you mentioned, I tried couple of times in chrome then started working and I’m able to login with required credentials.

Reg below error, Its showing in chrome also for each release in project, hopefully new release will fix this issue.

and also I’m unable to see the Task log for previous successful deploy for all releases in any project after upgrade the version. This is very important for audit purpose to have history of application deploys. is it bug in new version or do I need to perform any configuration after upgrade the version?

Octopus v2019.5.0

Sequence contains no matching element
System.InvalidOperationException
at System.Linq.Enumerable.Single[TSource](IEnumerable1 source, Func2 predicate)
at Octopus.Server.Web.Api.Actions.ReleaseTemplateAction.ExecuteRegistered(String id)
at Octopus.Server.Web.Infrastructure.Api.Responder`1.Respond(TDescriptor options, NancyContext context)
at System.Dynamic.UpdateDelegates.UpdateAndExecute3[T0,T1,T2,TRet](CallSite site, T0 arg0, T1 arg1, T2 arg2)
at Octopus.Server.Web.Infrastructure.OctopusNancyModule.<>c__DisplayClass14_0.<get_Routes>b__1(Object x)
at Nancy.Routing.Route.<>c__DisplayClass4.b__3(Object parameters, CancellationToken context)

(Shannon Lewis) #5

I’ve actually just merged the PR for this fix, and we’ll try to get the patch out tomorrow morning our time. It’s purely a code bug with one of the APIs used when rendering the page, so the data is all still intact and you won’t need to configure anything after the upgrade, it should just go back to rendering correctly.

Regards
Shannon

(Ramana Rainn) #6

Hi Shannon,

Is there any update on patch or any version released for Octopus Deploy?

(Ramana Rainn) #7

Hi,

I’ve upgraded it to latest version v2019.5.3 but still I’m unable to see the Task log for previous successful deploy for all releases in any project after upgrade the version.

Has anyone reported this issue for this version?

(system) closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.