Not able to install tentacle on linux

Hi team,

We are trying to install tentacle on linux server but are failing with below error .
Could you please help us here.

[root@XXXXXXXX scripts]# /opt/octopus/tentacle/Tentacle service --install
Could not detect systemd, systemd is required to run Tentacle as a service
[root@XXXXXXXX scripts]# cat /etc/system-release
Amazon Linux AMI release 2018.03
[root@XXXXXXXX scripts]# cat /proc/version
Linux version 4.14.193-113.317.amzn1.x86_64 (mockbuild@koji-pdx-corp-builder-60005) (gcc version 7.2.1 20170915 ( Red Hat 7.2.1-2) (GCC)) #1 SMP Thu Sep 3 19:08:08 UTC 2020

Regards,
Alisha

Hi Alisha,

Thanks for getting in touch!

It sounds like there may not be a unit file for the tentacle in /etc/systemd/system.
How was the tentacle instance created?
Did you use the configure-tentacle.sh script?

We have further details on installing the Linux tentacle here: https://octopus.com/docs/infrastructure/deployment-targets/linux/tentacle

Regards,
Paul

Hi Paul,

Thanks for replying.
I have used the below script to install tentacle.

OctopusUrl=“https://xxxxx.com
thumbprint=“XXXXXXXXXXXX”
name=$HOSTNAME
config_path="/etc/octopus/default/tentacle-default.config"
app_path="/home/sa-nprdoctodeploy/Applications/"

export https_proxy=http://proxy.nprd-speedpay.com:8080
wget https://rpm.octopus.com/tentacle.repo -O /etc/yum.repos.d/tentacle.repo
yum install -y tentacle
/opt/octopus/tentacle/Tentacle create-instance --config “$config_path”
/opt/octopus/tentacle/Tentacle new-certificate --if-blank
/opt/octopus/tentacle/Tentacle configure --port 10933 --noListen False --reset-trust --app “$app_path”
/opt/octopus/tentacle/Tentacle configure --trust $thumbprint
/opt/octopus/tentacle/Tentacle register-with --server $OctopusUrl --name $name
/opt/octopus/tentacle/Tentacle service --install --start
systemctl stop Tentacle
sed -i ‘s/root/sa-nprdoctodeploy/g’ /etc/systemd/system/Tentacle.service
systemctl start Tentacle
systemctl enable Tentacle

Regards,
Alisha

Hi Alisha,

I did a bit more digging and it turns out that Amazon Linux AMI release 2018.03 doesn’t include systemd.

Amazon Linux 2 does include systemd, so, if possible using that instead would be the best option.

If that is not possible, then you may be able to configure the tentacle service using an init.d script as described in the answer here: https://unix.stackexchange.com/questions/20357/how-can-i-make-a-script-in-etc-init-d-start-at-boot

Regards
Paul

Thanks Paul for the solution.
However when i run command to install the service it is showing requirement of systemd itself.
Does this mean tentacle is not installed as service?
The link you have provided is to start/stop service as per my understanding , but how do we install the service on this linux box.
Please correct if i am not going in the right direction.

[root@SPQPWAPP04E1B ~]# /opt/octopus/tentacle/Tentacle service --install
Could not detect systemd, systemd is required to run Tentacle as a service

Regards,
ALisha

In order to install it as a service, systemd needs to be available, which isn’t the case on your current VM.

The init.d method would essentially allow you to mimic the service by adding the tentacle run command to the script and configuring it to run on startup.
This isn’t a method that we have documentation for, so other than advising that it should be possible, I don’t have much else I can provide on it.

The best option may be to use a VM that has systemd available.

Thanks Paul, that helped. I used init script to install service.

1 Like