No script syntax provided warning

We have recently started seeing warnings across a number of our projects using the PowerShell script deployment step:

No script syntax provided. Defaulting to first known supported type PowerShell 

This is despite the script content saying ‘PowerShell script’ as shown below:

This is a little confusing and there doesn’t seem to be any mention of specifiying the syntax in the Octopus documentation, we are running v.2018.7.1



Hi Luke,

Thanks for getting in touch! I believe this issue has been resolved for theAzure PowerShell Scripts and AWS CLI Scripts steps.

I have a GitHub issue which covers this, however it looks like there are still some occurrences of this issues.

To resolve this you will need to upgrade to at least Octopus version 2018.7.3.

Let me know if this helps, or if you are still running into this issue after upgrading. :slight_smile:

Best regards,

That works thanks, upgraded to version 2018.7.5

Hi Luke,

Thanks for the update here. Please feel free to get in touch at any time. :slight_smile:

Best regards,

Hello Daniel,

We are currently on 2018.7.7 and we still are seeing the error “No script syntax provided. Defaulting to first known supported type PowerShell”.

We are using a step template called Encrypt Web Config Section. Any help would be much appreciated!

Thanks so much!


yes we have the same issue. Upgraded to 2018.7.7 from 2018.6.10 on Monday and now have this warning. I have seen and replied to a github thread

Using all sorts of step templates that use PowerShell and PowerShell is selected. Costing us a lot of time currently. As above, any help would be appreciated.


It looks like a new issue has been raised around this - thanks.

This issues is still open.
I get the warning:

No script syntax provided. Defaulting to first known supported type PowerShell

on all Run a script Step Templates with the following settings:

  • Script Source: Source code
  • Script Content: PowerShell

Recreating the step solves the problem. Also switching to a different syntax, saving and then switching back solves the problem.

Exporting the project shows the steps that raise the warning have the following json:

        "Properties": {
          "Octopus.Action.Script.ScriptBody": "script"

The steps that don’t raise the warning:

        "Properties": {
          "Octopus.Action.RunOnServer": "false",
          "Octopus.Action.Script.ScriptSource": "Inline",
          "Octopus.Action.Script.Syntax": "PowerShell",
          "Octopus.Action.Script.ScriptBody": "script"

Hi @tojnk & anyone else reading,

As per the linked GitHub issue above (And here). This issue should be resolved in our next minor release. 2018.8.0.

We are aiming to have this release out very early next week. (We operate on AEST)

Feel free to reply here or open a new ticket if you still notice this issue anywhere after the upgrade. :slight_smile:

Best regards,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.