No matching step could be found in the latest release


I have just changed the server/environment I am deploying to for a number of projects (all under the same project group).

It was previously working but now the octocpus.txt log states:

2015-06-05 17:04:53.2407 55 WARN No release created for project ‘PTP.Admin’ when package PTP.Admin version 0.0.5634.28930 was pushed. No matching step could be found in the latest release.

My configuration here (for the admin site) is:

Deployment Process

Automatic Release Creation = Yes

Deploy Nuget package:
Machine Roles: Server3
Nuget packageId: "PTP.Admin"
Environments: Server3
Custom Install Directory: C:\Websites\etc\etc\etc

Life cycle

Phase 1
Environments = Server3

If you need any additional information etc please let me know.


I should have mentioned that the change that broke this was when I changed the deployment from server 2 to server 3.

Hi Andrew,

Thanks for reaching out. May i ask what version of Octopus are you running? we’ve fixed a couple of issues around Automatic Release Creation on 2.6.4 - 2.6.5 that might cause behaviors similar to this one.

If you are already on the latest Octopus version ( Could you please send us the following?

  • A screenshot of the overall deployment process. Make sure the right panel where the checkbox for “Automatic Release Creation” is fits on the screenshot
  • A screenshot of the lifecycle configuration being used by the project “PTP.Admin”
  • The full Octopus.txt log.



We just deployed Octopus Deploy and encountered this same error. Here is what I found (our configuration may be different than the norm).

We believe we have found a BUG in Octopus that causes this error message.

A little background:

  1. We have Global variable sets that we are using to drive a lot of Network IP configuration, hostname creation, app-pool name creation, site name, F5 toggling, etc…
  2. We created a step template to use to deploy our sites with, in an automated deployment cycle for our Dev environment.
  3. We are integrating with TFS and using our build server to push packages to the Internal Nuget feed in Octopus.
  4. We are using Project level variables to drive the package name to deploy.

Our project configuration looks like this:
Automatic Release Creation enabled, pointed to the “Auto Deploy” step.

  • 1 step, “Auto Deploy” using the built in “Deploy NuGet package” step. We then configure it to have a custom install location and auto setup/update IIS (on Server 2012R2).

Imported Global variable sets" Company.F5, Company.Infrastructure, Company.Web, Web Configs - all of these are used to derive custom settings in the Deploy NuGet package.

  • Company.Project.AppName - “prototype”
  • Company.Project.Package.Name - “prototype”
  • Company.Project.AppPool.ServiceAccountPassword
  • Company.Project.SubDomain (used for custom URL, site, app pool, etc… creation)

Release Versioning: “Use the version number from an included NuGet package” - Auto Deploy (the name of our step in our Process)

Deploying the package:
In TFS, we have our build configured to auto deploy when a developer checks in code for Continuous Integration. This then uses OctoPack to push the code into the built in Octopus NuGet feed. - This works beautifully and we have no issues.

When the “Auto Deploy” step is configured to use a specific Package name (fig 1.1 in attachment) the Auto Deploy feature works correctly and all is well.

OK, so now comes the possible bug:
We have over 100 custom apps that we are looking to integrate into Octopus and as part of this I want to create a step template that encompasses the configuration of our sites, and IIS, and such and have our Project Process only include this one step template and fulfill the package name using a Project Variable.

When doing so (fig 1.2 in attachment) the release is never created.

That leads me to believe there is a possible bug in:

  1. Process - Automatic Release Creation - not recognizing the Variable driven name
  2. Settings - Release Versioning (Use the version number from an included NuGet package, step “Auto Deploy”) - not recognizing the Variable driven name
  3. something else :slight_smile:

Since there is a new package created and deployed to the internal NuGet feed one would expect this to work (and does when HARD CODED, not VARIABLE DRIVEN)

I have tried setting up a step template and driving it with a project level variable, modified the step template to include a parameter that is set per Package, and have also tried putting the Deploy NuGet Package step in directly. None of these work if I use variables.

I have not tried creating a step template with a hard coded package name, but that would defeat the purpose of what I am trying to accomplish here.

I have hard coded the value to the package in the Deploy NuGet Package step and seen it work, and have modified that exact same step to use a Project Variable and it not work. - I have NOT tried to use a Global Variable.

Perhaps this is by design, but it feels like I should be able to do what I am attempting here.

Any thoughts? I’d be happy to setup a WebEx with an Octopus Employee to demonstrate.

Kyle S.

Octopus_3.0.10.2278_Possible_Bug.pdf (387 KB)

Hi Kyle,

Thanks for reaching out. The fact that Automatic Release Creation (ARC) doesnt work with variables is as design. There is a uservoice suggestion that is becoming pretty popular to support the use of variables with ARC:

Please drop by and add some points (and why not a comment) to the suggestion if you’d like to see it implemented in upcoming releases.