"No git resource with the name" error converting project to config-as-code

We are attempting to convert an existing project to use version control on a feature branch. Clicking the Test button reports all ok, but clicking Configure and filling out the commit details, causes Octo to sit and think for a while before returning the error: “No git resource with the name ‘XXXXXXXXX’ exists in the repository.”

The diagnostic logs shows a list of warnings like: "git-op on “CZ5XMRZ3E46LVLVDXO7G6ZBBIBTQN7MX” root: Couldn’t find upstream branch wih name ‘“refs/heads/XXXXXXXXXX”’ (note the typo in the warning… not sure if there is a bug report for that already).

The only difference we can see between a working repo and this one is this has over 250 branches. I only mention this as clutching at straws as to the cause.

Troubleshooting steps we have tried so far:

  • Verified the branch exists on the remote server
  • Checked configured git credentials and verified them working by creating a new project with VCS to a different repo.
  • Verified user creds have write permissions to the branch by using the same credentials to push a commit to the branch
  • Tried a different branch on the same repo. Same result.
  • Tried a different project, Same result

We are running on-prem Octopus server v2022.2.7822 and have source control in bitbucket cloud.

Hi @adam.eastbury,

Thanks for reaching out to Octopus Support, and I’m sorry that you’re having issues configuring your project’s version control.

We have encountered a few issues with specific repo configurations, so I would like to gather some more information to see if perhaps you are running into something that we’ve seen before.

Would you mind sending us a copy of your Octopus Server log after an attempt to configure this project? I will send you a secure upload link you can use rather than send anything via the forum.

Can I also have some more information regarding this repo? Aside from the branches, could you also let me know the size of the repo as well as how many tags you are using? We’ve seen combinations of these three things cause problems in the past.

I look forward to your response, and if you have any other questions, please let me know.

Thanks!
Dan

Thanks for the reply. I will get those file and info over to you via the secure link and PM

1 Like