New "Run Script on Server" step not shown

I upgraded from 3.2 to 3.3.0-beta0001 this morning, on a WinServer2012R2 machine (non-clustered). Upgrade appears to have gone fine, except the new features don’t seem to be present. I also forced the Calamari upgrade and there was no change.

Attached screenshot shows the available list of step types when attempting to add a step. The list is the same when adding to a new project’s process or a previous one. Notice that it is missing all the new shiny ones.

Is there an additional step needed to enable the new step types?

Issue solved - the solution was to “Reinstall Service” from the server manager, despite having stopped and restarted the service while the upgrade installed.

Hi Tyler,

Thanks for getting in touch and letting us know of your troubles.

Sometimes when it comes to UI related issues like that, a hard refresh in your browser can resolve the issue as well as the browser caches the javascript.

Good to hear though that you were able to resolve the issue, but I’ve made the team aware of your issue and we’ll take a look at it.

Thank you and best regards,

After upgrading v3.2 to v3.3.1, the Run Script on Server step is not showing for us either.

Steps taken so far:

  • Run Reinstall Service
  • Run install’s Repair step
  • Restarted server
  • Closed browser
  • Cleared browser cache

Can you suggest any additional steps?


Hi Rick,

Thanks for reaching out. On 3.3 you need to add a regular Powershell script step, and then select to run it from the Octopus server. Can you see that option as shown on the attached screenshot?

Best regards,

Forgot to attach screenshot

Yes. It’s there, I’m good to go now. Thanks!!