Need Help in Octopus HTTPS Binding

Hi,

We are very new to the Octopus deploy so we have installed Octopus on our DEV box first to do the testing. Now the Octopus Deploy 3.2.11 has been installed but we are working in a very secure environment and we want Octopus web portal on https with SSL.

The HTTP and HTTPS bindings works fine when I use the host name as “LOCALHOST” however when I change the host name to our desired name like abc.com then neither HTTP or HTTPS works. I know hostname should be same for http and https but my issue is that if I use any other name other localhost it gives me page can not be displayed and I am browsing the web portal on the server so I don’t think it needs to be on DNS to make it work. We will create a DNS name when everything works fine.

Kindly advise if I am missing something and also what else needs to be done for running it on https with SSL?

I would appreciate any help in this matter.

Thanks
Manish Sharma

Hi Manish,

Thanks for getting in touch. I’m assuming you’ve already found our documentation page on this, but if you haven’t it’s available at the following URL.

That said, can you tell me if you’re updating the Octopus bindings to use the new hostname? It should look something like the attached screenshot. I changed the bindings from localhost to the machine name and it works fine.

Let me know how you go.

Thanks

Rob

Thanks Rob for your quick reply.

I have read the documentation already. Here is my scenario.

By Default the Octopus instllation sets the default URL as http://localhost/OctopusDeploy which works fine however when I remove the current binding and add https://abc.zyz.com/octopusdeploy then it stops working.

We want this to work on https only so I removed the http binding.

Let me know if there is anything else needs to be done.

Appreciate your help in this.

Thanks
Manish

Hi Rob,

I got it figured out, I did not have that name on DNS and then I have edit the host file to make it work on https port 443.

That works fine now however I have a another question, how do we enable force SSL? I can see on Octopus Manager as FORCE SSL - N0. I did not see any option when setting up bindings and I have set the force SSL as true in config file. however it still shows force SSL NO.

I would really appreciate if you could guide me how to enable ssl as I couldn’t find it in documentation.

Thanks
Manish

Hi Manish,

Nice work! It’s great to hear you got it configured. In regards to your question, “Force SSL” is set to YES when you have an HTTP binding and a HTTPS binding and you set the “Redirect HTTP requests to HTTPS (recommended)” option. If you only have an HTTPS binding, then it doesn’t apply. Screenshot 1 shows an example of this.

Hope this helps!

Rob