Multiple "No Managed Code"


We are using Octopus 3.4.2 currently. I have successfully configured a .NET 1.0 Core project. In a step to create the AppPool, I am setting the Managed Runtime Version to “No Managed Code” as below:

(Attached image 1)

This works fine for the first time, but on second release onwards, it creates a second option in Application Pool setting as below. Obviously this causes the application to fail (though the release succeeds). If I then manually change the .NET framework version to the first “No Managed Code” option in the dropdown, the app starts working again.

(Attached image 2)

Thanks in advance,




Thanks for reaching out! It seems like the template you are using from our library wasn’t prepared to set pools to “No managed code”. I’ve sent a PR to get this fixed.

In the meantime please use this version of the template with the fix. It should give you a dropdown option to set it to “No managed code”:

Let me know if that works,

Thanks Dalmiro,

I used the template you mentioned and it resolved the issue.

Thanks again,

Dharmesh - Glad to hear that worked for you!

For anyone else running into this issue: The PR with that fix has been merged and you should now be getting the latest version of that step template from our Library:



This issue has been closed due to inactivity. If you encounter the same or a similar issue and require help, please open a new discussion (if we asked for logs or extra details in this thread, consider including them in the new thread). If you are the creator of this thread and believe it should not be closed let us know via our support email.