Modify Terraform Default Init Command?

Hello,

I am currently trying to deploy a terraform template using version 0.15 of Terraform. I’ve added the worker machine and everything runs correctly but the ‘terraform init’ command fails. It looks like the command run by calamari is as follows: 'terraform init -no-color -get-plugins=true ’

However, the -get-plugins optional parameter has been deprecated in favor of ‘-get’ since version 13. How can I reconfigure the init process to use the correct parameter?

Hi Brian,

It looks like you are correct.
The “Deploy a Terraform Template” still uses that same command even in the latest version of Octopus.

I’ve raised a public issue regarding this:

Please jump over to the github issue and hit subscribe to follow updates on the issue.

The only effective workaround for the moment would be to revert to an earlier terraform version using Octopus.Action.Terraform.CustomTerraformExecutable:

I will make sure to update you if we get some progress.

Regards,

Dane