Missing Watchdog Task

PS C:\windows\system32> & “C:\Program Files\Octopus Deploy\Tentacle\Tentacle.exe” watchdog --delete --create --instances * --interval 10
Removing watchdog task
Creating watchdog task
Setting watchdog task interval to 10 minutes
ApplicationName: Tentacle
Instances: *
Scheduled task Octopus Watchdog Tentacle not found. Nothing to do.

What I do wrong? I’m sure that this command, with " --instances *", worked OK so far, but now it can’t create Task Scheduler.

Nothing interesting in C:\Users\xxxxx\AppData\Local\Octopus\Logs\OctopusTentacle:

2021-04-01 11:54:04.1258 8116 1 INFO Tentacle version 6.0.492 (6.0.492) instance Default
2021-04-01 11:54:04.1571 8116 1 INFO Environment Information:
OperatingSystem: Microsoft Windows 10.0.17763
OsBitVersion: x64
Is64BitProcess: True
CurrentUser: MACHINE\xxxxx
MachineName: MACHINE
ProcessorCount: 8
CurrentDirectory: C:\windows\system32
TempDirectory: C:\Users\xxxxx\AppData\Local\Temp
HostProcessName: Tentacle
PID: 8116
2021-04-01 11:54:04.2978 8116 1 INFO Search for .env file, starting from C:\Program Files\Octopus Deploy\Tentacle
2021-04-01 11:54:04.2978 8116 1 INFO No .env file found
2021-04-01 11:54:04.4539 8116 1 INFO Using config from C:\Octopus\Tentacle.config
2021-04-01 11:54:04.4852 8116 1 INFO Changing log folder from C:\Users\xxxxx\AppData\Local\Octopus\Logs to C:\Octopus\Logs

Ok I get it now, there has to be 2 independent runs of exe, one with --delete and then second with --create.
That way scheduler is created properly.
But just as I’ve wrote before, I’m pretty sure that single command with both --delete and --create worked fine before, in previous versions.

Hi Rafal,

I believe it should work with both arguments in the same command, but it could be that something specific to that machine was causing a problem.
Glad to hear that you were able to get it working by using each command individually.

Regards,
Paul