Missing release notes on external feed when update from 3.3.17 to 3.4.5

Hi, we just update from 3.3.17 to 3.3.4. In 3.3.17 when view the summary of a release, we see the diferent packages and their release notes (see release_notes.png). But now, in the latest versión, we only see the Package Name and their Description. Where we can view the package release notes now? We are using external feed, not built in nuget server



Hi Fernando,

Thanks for reaching out!

I tried reproducing this using on my end but I couldn’t do it. Could you help me with:

  • Send me the raw markdown text that your packages have as descriptions so I can put it on one of my packages and test it out.

  • Tell me which nuget feed technology are you using. Myget, Nuget.server, TeamCity feed, etc?


Hi Dalmiro:
Some release notes example (attached ReleaseNotes_ex.txt)
See the previous screen shot (we not change any release notes between Octopus Server update).

External Feed:
Nuget feed: running NuGet.Server v2.10.0.0


ReleaseNotes_ex.txt (1 KB)

Hi Fernando,

Thanks for sending over that info. I can see the markdown rendering on my end, though not exactly like in your initial screenshot (see attached one).

Which browser on which OS are you using? Any chance you can try on Chrome?


See attached file (release_notes.txt) the complete release notes file that i send in the screenshot.

(ReleaseNotes2.png) with the HTML render of this release notes.

I don’t think is a navigator related i use Chrome, Firefox, Safari, Explorer, Edge… same result. As i say, the problem becames when update to the new Octopus server version, we don’t do any packages changes. Octopus 3.3.17 render release notes fina, 3.4.5 missing release notes :wink:

Thanks in advance

ReleaseNotes.txt (3 KB)

Hi Fernando,

  • Could you open your browser’s developer tools, go to the Network tab, reload that release page, look for a call to /api/feeds/[FeedId]/packages/notes?packageId=[PackageID]&version=[Version] and send me the full response you get from it?

  • Could you also try to use the attached package and let me know if you see the release notes when you try to use it in a release? I had to add a .zip extension to it so the forum would let me upload it. Make sure to remove that before testing.

ReleaseNotesTest.1.0.0.nupkg.zip (3 KB)

Hi Dalmiro

Here is the full response for the request:


Published: lunes, 12 de septiembre de 2016 8:15

The SCE2 deployment package, built on 27/06/2016

Only title and description, no release notes.

Also, we don’t see the release notes with the attached test package :frowning:


More testing, the same attached package using Built In Feed show the relese notes but without markdown format

HI Fernando,

I took some time to reproduce this using a Nuget.Server feed and I also found that the release notes are not showing up.

Also as you mentioned, the release notes are not getting properly formatted while using the built-in feed. I did a quick test on a gist to double check how they should look in order to confirm this.

I’m gonna forward this findings to the team and get back to you as soon as we can.

Best regards,

Hi Dalmiro, any update regarding this issue?


Hi Fernando,

Deep apologies for the delay here. Somehow this ticket got left out of my queue.

I’ll get back to you after I get in touch with the team tonight.


Hi Fernando,

I had our dev team check this out last night and it turns out that the Nuget 3 API (which is the latest version, and what we use in Octopus) does not return release notes. There’s even an open issue/feature request to bring this back in the Nuget repo: https://github.com/NuGet/Home/issues/1823 (I commented on it asking for an update)

We believe our only way around (until the Nuget team fixes this) would be to download the full package at release creation time simply to get the release notes. This will though come with a lot of things to think about:

  • What if the package is too big? downloading a 200mb package just to get Release Notes could be troublesome in many scenarios.

  • What happens if the user uses a Variable to define the package ID. At release creation time that variable still wont have a value and Octopus wouldn’t know what to download.

At this point we think the most prudent thing would be to wait for an answer from the Nuget team. Patching this ourselves might be a workaround that could end up breaking more things than it fixes.

Sorry my reply sucks so bad :frowning:

Best regards,

Hi Dalmiro, thanks for the answer. I am very surprised for the reason :frowning: Release notes are a very important part of our deployments.

Regarding to the way around if you select the option in release creation time (nuget package step):
Octopus Server will download the package, then securely upload it to the Tentacles , is not a problem, in this case Octopus server have to download it.

In any case thank you very much for research. I hope that release notes can come back soon to our deployments.

Best regards,

Hi Fernando,

Thanks for understanding. It really is a pain that Nuget isn’t exposing the release notes yeah. The Octopus server will donwload the package to push it to the Tentacles only during the deployment, not at the time of creating the release. That’s why i was saying that at that stage, the Octopus Server still doesn’t have the package.

Sorry its a crappy answer. If possible try to ask on the github issue(just like I did) to show the Nuget team that enough people care about this.



This issue has been closed due to inactivity. If you encounter the same or a similar issue and require help, please open a new discussion (if we asked for logs or extra details in this thread, consider including them in the new thread). If you are the creator of this thread and believe it should not be closed let us know via our support email.