Manager starting slow

I’m on the trial and I’m having problems opening the manager.

  • Run the manager
  • prompts for admin login
  • window opens checking settings and roles (takes about 40 minutes)
  • new window ‘searching for octopus deploy installation’ (takes about 40 minutes)

Eventually opens.

Hi Richard,

Thanks for getting in touch!

Can I ask what version of Octopus Deploy you’re using? One of the potential causes for this may be a Certificate Revocation List check that gets run by .NET.
We released a fix for this in version 3.0.23 that may fix the issue.

A couple of other potential causes may be:

  • A very slow Octopus Server (however I’d imagine you’d be aware of this)
  • A slow or problematic connection between the Octopus Server and the SQL Server

It may also be worth checking both the Octopus Server logs and the Windows Event Logs to see if there are any hints there.

Hope that helps!

Hey Damo,

I think I’ve worked out the issue. I have a number of versions of SQL server installed, opening up management studio seems to fix the issue. This is likely due to windows services running on delayed start. I’ll take a look into that.


Hi Richard,

Thanks for the reply, I’m glad you’ve worked it out!