Login Failed to a Docker Registry configured as external feed (JFrog Docker Registry) (

Hello! We have a Cloud Instance of Octopus Deploy which uses polling tentacles (2 worker nodes) to deploy things inside a Private VPC in AWS. We have configured an external feed to JFrog that allows us to authenticate and pull images from there:

for some reason, which I already regret, I used one of the worker nodes to login into a private docker hub registry. So now, one of the two workers has the Docker Hub credentials and is affected when pulling images from that worker while trying to deploy an image using Octopus Cloud and the JFrog repository. We get the following error:

Error saving credentials: mkdir octo-docker-configs: permission denied 
Login Failed 
Failed to download package od-debian ve07274dc from feed: 'https://bairesdev.jfrog.io/public-docker-registry' 
Unable to log in Docker registry 

I tried manually login in to our private Jfrog docker repository from the worker that I did the changes, but I can’t make it work again. Somehow, that particular worker is not getting the credentials from the feed.
When I use the worker that I didn’t touch, It works fine.

Any suggestion?

Thank you very much in advance!

Cheers,
Nicolás

Hey @nicolas.spencer,

Thanks for reaching out on our community forums!
Sorry to hear you’re experiencing issues.

I wonder if the issue you’re coming across here is due to local file permissions on the worker in question?
The first line of the error you’ve linked seems to hint at failing to create a directory “octo-docker-configs”, which I believe is where the feed credentials and other configuration data is stored.

Would you be able to check permissions on the docker install folder (I assume that this is where the file is created or located) to be sure that the service account your Octopus worker is running under has read and write permissions?

Please let me know the outcome of this and we can troubleshoot further based on that.

Kind Regards,
Adam

Hi @adam.hollow, thank you for the quick response. Following your answer, I could verify that something was not right with the permissions and the folder structure from docker. Since I disable that worker, I decided to uninstall and install docker again and that solved the problem. I know that it wasn’t an elegant solution but It worked :grinning:

Thank you for the quick response, I really appreciate it.

Cheers!
Nicolás

2 Likes