Local fileshare feed

Hi guys,

I am trying out a local fileshare within a hidden path:

Ex: \\server\HiddenFolder$\Packages

I can set it up in Octopus no problems, and there is no issues as far as i can see with permissions. But when testing for packages there is none found. No warning in logs.

Have tested the localfeed in VisualStudio where it works as expected.
Is hidden fileshares not possible? Or am I seeing something else?


Thanks for getting in touch! This seems to be working on my VM. I may need to get some further information to help troubleshoot this.

What version of Octopus server are you currently using?

If Octopus was not able to find the directory I believe it would provide an error saying so. Having no error seems to suggest that it is connecting but something else is going wrong.

Are you able to attach some screenshots of your configured external feed in Octopus and what happens when you try to test this?

What OS/Version server is the feed on? Where is it located relative to the Octopus server?

Looking forward to hearing from you and getting to the bottom of this. :slight_smile:

Best regards,

Octopus is v2018.3.12.

I am not sure this is actually related to hidden fileshares. Tried to use a local directory instead with same issue. When using the Test functionality in the feed there is no error, just show no packages and no errors. Have tried changed the feed to a non-existing share, and then I get an error.

There is no nuget server, but the fileshare server and octopus is on the same onpremise network. Not sure about the server versions at this stage, will have to contact our Intrastrcture guys for this details. Will follow later, if needed…

As additional information, I have changed the build-in feed to use the same fileshare, which works fine…

Could it be releated to the way the package was pushed to the local feed?
Have created a dummy package via the Nuget Package explorer, and pushed via Nuget Cli:
nuget add MyPackae.nupkg -Source \filessharepath.

Is this enough info for futher debugging?



Think I found the issue.

Pushing via nuget CLI, the package versions is stored in a versioned directory. As also described in https://docs.microsoft.com/en-us/nuget/hosting-packages/local-feeds.

But when testing with octopus only packages stored in root is found.
Problem here is we need a local nuget feed that we also can use in VisualStudio. And VS nuget explorer will not display packages in root…

Is this intended behaviour?