Linux Tentacle support for Ubuntu 22.04

Hello! Is there any plan/timeline for updating the Linux Tentacle to support running on Ubuntu 22.04 LTS?

There currently seems to be an issue with a dependency on libssl <= 1.1 which is no longer supported.

Trying to install the tentacle deb package gives the following error:

The following packages have unmet dependencies:
 tentacle : Depends: libssl1.0.0 but it is not installable or
                     libssl1.0.2 but it is not installable or
                     libssl1.1 but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve also tried downloading the archive package and running it manually, but Tentacle also fails with a libssl error:

No usable version of libssl was found
Aborted (core dumped)

The supported distributions only lists Ubuntu 18.04 LTS and Ubuntu 16.04 LTS, although the Tentacle does seem to work OK on 20.04 as well. For Debian as well it only lists 9.12 - so both distros are missing support for the last two LTS versions.


Hi @wayne_turner_3,

Welcome to the Octopus Community!

That’s a great question! It looks like the devs are in the final stages of testing all of our supported linux distributions (debian included) and will be updating the docs once they’ve finished.

As you’ve found, the main issue seems to be with libssl is no longer being included by default on 22.04 distributions and is relied upon by current builds of Tentacle.

For a workaround until we’ve released a compatible build of Tentacle, you should be able to use the following commands to install the missing libssl package from the impish-security repository:

echo "deb impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list
sudo apt update
sudo apt install libssl1.1

Let me know if you have any questions or if you still run into issues with it!

Best Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.