Linux deployment using sSH (Package.InstallationDirectoryPath)

(Nikesh Jauhari) #1

hi,

We are on 90% Linux based systems
I am doing a small POC where we are tryin to do a small deployment on AWS EC2 linux. (using ssh deployment)

Deployment Steps:

  • get the package (war) file from the repo
  • move the war file to another location from the default octopus location.

I am not able to get the package installation dir in my deployment script (bash) - post deployment

echo “$(get_octopusvariable “Octopus.Action[Deploy Tomcat WAR].Package.InstallationDirectoryPath”)”
echo “$(get_octopusvariable “Octopus.Action[Deploy Tomcat WAR].Output.Package.FilePath”)”

I am not able to get any output from above variable.
Any idea what’s wrong here ?

Thanks,
Nikesh

#3

Hi Nikesh,

Thanks for getting in touch!

Sorry that you’re having problems here. For the first variable are you able to make a slight change and test again?

echo “$(get_octopusvariable “Octopus.Action[Deploy Tomcat WAR].Output.Package.InstallationDirectoryPath”)”

If that still fails are you able to let me know which steps you are using in your deployment process to deploy the package (presumably a WAR file based on name) so I can investigate further on this side?

I’ll also take a moment to quickly mention that we now have an (early access) version of Tentacle for Linux, this may help with your PoC.

Thanks Nikesh, I look forward to hearing from you.

Regards,
Alex

(Nikesh Jauhari) #4

thanks Alex,
I am doing a very simple steps where …

  1. Get the WAR file from the repo
  2. Use the JAVA JAR package manager to drop the war on octopus default location
  3. Read the value of this default location and copy the WAR to new location

I tried and still I am getting the wrong dir path

Output from Step # 2
Deploying: /home/ec2-user/.octopus/OctopusServer/Files/Feeds-2/com.adp.ts%3ARiskIIPP@M1.0-SNAPSHOT@6C8AF03A9E66714E9F49982754D958CC.war
Re-packaging archive: ‘/home/ec2-user/.octopus/Applications/OctopusServer/DIT/com.adp.ts%3ARiskIIPP/1.0-SNAPSHOT_31/com.adp.ts%3ARiskIIPP@M1.0-SNAPSHOT@6C8AF03A9E66714E9F49982754D958CC.war’

Output of the Step # 6
echo “$(get_octopusvariable “Octopus.Action[Deploy Tomcat WAR].Output.Package.InstallationDirectoryPath”)”

Installation PATH --> /home/ec2-user/.octopus/OctopusServer/Work/20190702133941-459-1661/staging

(Nikesh Jauhari) #5

Any updates ?

#6

Hi Nikesh,

Apologies for the lack of updates here.

I’m still not convinced that I understand your deployment scenario. So that I can get to a resolution quickly would you be able to send through some screenshots of your deployment process, along with a JSON export of your deployment process?

Thanks Nikesh, I look forward to hearing from you.

Regards,
Alex

(system) closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.