License limits have been exceeded

I’ve just migrated octopus 3 to a different server, using the community edition. I left the old server running and am now getting the following error on the new server:

There was a problem with your request.
Unfortunately your license limits have been exceeded, and you will no longer be able to create or deploy releases. Your Octopus Deploy license only allows 1 active node. You currently have 2 active nodes.

I can’t figure out how to clear this, shutting down the old server hasn’t fixed it, nor restarting the new one. I noticed that the new server had reverted to the trial key, I’ve set it back to community. How do I fix this?



Actually, now I’m receiving this error on a customer’s CE octopus that I upgraded today. I really need to get their Octopus back online. Is there some kind of new call home function in 3 that is linked to an email address? I’m thoroughly confused as to why you would do this??

Hi Paul,

Thanks for getting in touch! Sorry about the troubles. I have to assume that when you created the new server and did the migration that you connected to the same database as the previous one? When you did this you create a new instance that connects to the same database. This is considered having multiple instances connected to the same database and two nodes.

You will need to either delete the first instance (using the Octopus Manager) to have it removed from the database, or (with very light hands) remove the first instance from the database in the OctopusServerNode table you will need to have only 1 entry for the new migrated instance the database is connecting to.

Hope this helps.

Thanks for the reply Vanessa. For the migration I backed up the Sql Db, moved it to a new server and used the master key to connect a clean installation to it. I definitely did not have two servers connected to the same database, they are in different VPCs. I’ll try the OctopusServerNode suggestion.

Thanks, that fixed it. I wonder if that’s the behaviour you are expecting? It would seem that when you move a database and octopus 3 server, you need to clean out the old entry from the OctopusServerNode tabl.? Maybe when a new server is being installed and connecting to an existing database, it should delete the stale node?

Hi Paul,

Great that it’s fixed. You are right it wasn’t an experience we would want anyone to have, and are currently in discussions to change this behavior. We did test previously with a migration to a new server, but not just copying the database directly from a backup. We are going to make the assumption that in this case we do need to clear that table.

Thanks for bringing this to our attention and for your feedback.