Key 'OPENSSH' is not supported


I’m setting up an SSH connection to a Fedora 31 server using Public/Private keys.

I’ve tested access form another Linux box and I can authenticate using my private key.

However, when I set up and test connectivity to the same server from Deployment Targets > Connectivity, I receive the error Key 'OPENSSH' is not supported.

I can’t find anything specific for Octopus, but other results point towards the version of SSH being too new. According to ssh -V, Fedora 31 is running OpenSSH_8.1p1, OpenSSL 1.1.1d FIPS 10 Sep 2019

Can anyone confirm if this is a version issue and if so, do I need to find an older version of SSH or is there a fix coming out?


I guess it is something to do with the version of SSH.

I tried using another box to generate the key-pair using ssh-keygen command which worked from OS to OS, but not from Octopus to OS.

I would never do this for a production system, but for this test, I generated the key-pair using:, which worked!

It would be nice if someone from Octopus could clarify if it is an SSH version issue.


I’m sorry for the delay in getting back to you. I’m just in the process of testing this out to verify the error and narrow down which versions are affected.
To ensure I have the same setup as you, can you send me your Octopus server version?

Once again I apologize for our slow response time.


Hi @Tina,

Apologies if I came across a pushy. Not my intension.
Version: 2019.12.4 LTS.


P.S. TIA = Thank you in advance :wink:

Hi Tex,
No worries. Sorry, it’s taken me so long but I’ve been testing away.

I was able to reproduce your error by creating the key-pairs on a Fedora machine hosted on a MacOS running the basic ssh-keygen command. Is that possible the case for you? I was able to get past this error by generating the key-pair using,

ssh-keygen -m PEM

If this is not the case for you please let me know and I’ll keep digging.

Kind Regards,

I had this problem because I was using a ed25519 key, ended up doing a 8192bit rsa key I think

1 Like