Jira Connect test 400

(seanl) #1

Just installed 2019.9.11 LTS, and I’m trying to get Jira connected.
After installing the Jira plugin and configuring Jira Base Url, Jira Connect App Password, and setting the Octopus Installation Id, I get this error message attempting to test:
Octopus Server Url is set to http://servername

image

(Shannon Lewis) #2

Hi,

Thanks for getting in touch. That looks like a BadRequest error coming back from Octopus server, which is curious because in all the scenarios I can see in the code it should be returning a more meaningful error message to display. Could you check the Network tab in the browser Developer Tools and look at the full details of the response from the server, to see if there are more details there that we aren’t surfacing for some reason?

Also, are there any proxies/firewalls or anything Octopus has to go out through to get to Jira? There is a known issue with proxy configuration not being applied correctly.

Regards
Shannon

(seanl) #4

We’ve verified that our firewall isn’t dropping traffic to atlassian.net, and we don’t require a proxy to get out to the internet.

DevTools doesn’t help, there’s nothing returned in the body.

I also don’t see anything in the OctopusServer.txt log file.

(Shannon Lewis) #5

Apologies that I missed this yesterday, could you check that you have set the Jira Issue Tracker’s enabled flag to true? When it’s disabled you can still configure these values but the APIs, include the one that does the test, will return a 400. We’ll look at whether we can return a better error here to make this easier to troubleshoot, or better yet see if we can remove the enabled check so that it doesn’t get in the way of testing the connection.

Regards
Shannon

(Shannon Lewis) #6

After some further discussion within the team, we’re working on a fix for this. These endpoints shouldn’t require the extension to be enabled and it’s caught a few people out.

You can follow the issue on GitHub for progress.

Regards
Shannon

(seanl) #7

Shannon, is there something I can enable while waiting for a fix?

(Shannon Lewis) #8

If you enable the Jira Issue Tracker extension the API should start responding and all functionality should work correctly. This is just a confusing message that occurs if you haven’t enabled the extension yet.

If you still get the error after enabling then let me know, as there could be something else causing it that we haven’t come across before.

(seanl) #9

That worked, thanks.