Issues with upgrading Octopus Tentacle

My customer has Octopus and the server was updated last Thursday by a co-worker to the latest version.

We are having major issues with the tentacle that wont upgrade neither manually or auto. If I try to manually update it I get in web GUI
Beginning upgrade
March 13th 2023 14:27:42
Access to the path ‘E:\Octopus Deploy\Octopus\Octopus.Tentacle.Upgrader.exe’ is denied.

I did upgrade it manually by downloading the latest version, but even tho I am running latest version in webgui it says I still need to upgrade and then we are back to the first error again.

I tried to reinstall the app on the server so it was using the E:\octopus deploy path (originally installed in C:\ drive by default) but that did not help neither. Also cant find thie file it is asking for either in any catalog.

The agent is running as local system. I have 12 agents and I could update them manually if this would resolve the issue but afraid it wont.

I also sent a ticket to support, but posting here as well in case anyone else struggle.

Hey @andre.nordstokke,

Thank you for contacting Octopus Support, I believe you sent a ticket via email to our Zendesk system with the same question which my colleague Adam has answered.

We will continue that conversation through emails if you do not mind so we are able to provide you with quicker answers, once we know the fix for this we will post it up here so other users running into this issue can see.

Kind Regards,

For anyone encountering this in the future:

Access to the path ‘E:\Octopus Deploy\Octopus\Octopus.Tentacle.Upgrader.exe’ is denied.
Server pushed upgrades require that the Octopus Service user account has access to the Octopus install directory.
Checking which user account the Octopus Deploy service is running under and verifying permissions to the install directory should rectify the issue.

Would like to point out this access denied had to be solved on the SERVER side. My co-worker started on client side and I continued searching there since he started there. Once we resolved the issue with access to the sub folder for the service user we managed to update all agents.

Big thanks for fast reply on emails, I am impressed.

Hey @andre.nordstokke,

You are correct yes the folder \Octopus Deploy\Octopus\ does not exist on the tentacle it is on the server side. But it was good you pointed that out just to ensure other customers dont go down a rabbit hole.

Thank you for the kind words too, we try and get replies out as quick as we can to customers to help them out!

Reach out if you need anything further,
Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.