Issue with Upgrade a Helm Chart step

Hi there,

I’m trying to deploy a Helm chart using the “Kubernetes > Upgrade a Helm Chart” step. I want to upgrade Helm chart using Helm Client version V3, but I got error:

My configuration:

Sorry If I duplicate threads but I cannot find solution on your site.

Thank you in advance.

Hi @kurtz,

Thanks for getting in touch!

Our dynamic worker images only have Helm 2.9.1 installed on them by default.

In order to run the step using V3 you would need to either create your own static worker with this version installed or make use of our execution containers feature to run a container that includes Helm V3.

Regards,
Paul

Hello @paul.calvert , thank you for your reply. I took execution containers “worker-tools v3.2.1-windows.ltsc2019”, but I got another error related with AZ - “Cloud not find az”. I need to install Az tool?

PS. Is this normal that I had to wait half hour to download/boot container?

That is unusual, I’m fairly sure that the Azure CLI should be included in the image.

Unfortunately, it can take some time to download the Windows images the first time on a dynamic worker. The file size is quite large due to the Windows OS. If possible, using the Ubuntu worker and container image would reduce the time significantly.

I’m setting up a test of this now, but, it may take some time to get a result due to needing to download the image on the worker.

Can I check what step type you’re using for Step 4?
If possible, a screenshot of the configuration of the step would be useful too.

@paul.calvert - Oh, okey. I think there is a little my mistake… In Step 4 I tried to “RUN A SCRIPT” where inline scripti is:

But what is interesting, even command like Write-Host ‘hello world’ finishes with same error:

obraz

One more thing - in this step I have no option execution containers.

I think it will be trying to use the AZ module due to the deployment target for the Run a Script step being an Azure-based target. So, it automatically attempts to use that module to authenticate.

In order to have the Execution Containers option appear you may need to change the Execution Location option from “Run on each deployment target” to “Run on a worker on behalf of each deployment target”.
Once that is selected the additional options should appear.

1 Like

Oh, okey. After changing the Execution Location I could take “Run on a worker on behalf of each deployment target” :sweat_smile:

One more thing - with Container image octopusdeploy/worker-tools:3.2.1-ubuntu.18.04 I got following error:

My settings:

It looks like it is trying to download the ubuntu image onto a Windows worker.
The step in your screenshot looks ok, but are there any other steps that are trying to use this image but could have the Worker Pool set to Windows?

Okey. I got it. I had to change Worker Pool under Deployment Targets settings :sweat_smile:

Be honest with you, the Octopus enviroment has quite entry threshold for me… But maybe step by step I configure my CI/CD environment.

1 Like