Issue setting up a new tentacle on Octopus 3.1.3

Hey there,

i’m having issues setting up a new tentacle after upgrading our octo server to the newest version. Couldn’t find any solutions…

After installing the tentacle (3.1.3) i get the following error message:

Connecting to server:
Connected successfully, Octopus Server version: 3.1.3
Authenticating as administrator…
Authenticated successfully
Getting available roles…
Error: You must be logged in to perform this action. Please provide a valid API key or log in again.
Octopus.Client.Exceptions.OctopusSecurityException: You must be logged in to perform this action. Please provide a valid API key or log in again.
at Octopus.Client.OctopusClient.DispatchRequest[TResponseResource](OctopusRequest request, Boolean readResponse) in Y:\work\refs\tags\3.1.3\source\Octopus.Client\OctopusClient.cs:line 457
at Octopus.Client.OctopusClient.Get[TResource](String path, Object pathParameters) in Y:\work\refs\tags\3.1.3\source\Octopus.Client\OctopusClient.cs:line 83
at Octopus.Client.OctopusRepository.MachineRoleRepository.GetAllRoleNames() in Y:\work\refs\tags\3.1.3\source\Octopus.Client\OctopusRepository.cs:line 690

I also tried various hostnames but nothing worked

The target mashines are Windows Server 2008 R2 SP1 and Windows Server 2012
I also tried an older tentacle version (3.0.21) on the WS 2008 R2 because of the SP1 Issue with the 3.1.3 tentacle.

Any ideas?



Thanks for reaching out. The hostname seems to be ok, as the wizard is able to resolve the Octopus server version. Could you double check that the account “Administrator” is in fact inside of the “Octopus Administrators” group?



Hey Dalmiro,

thanks for your response. Yes the ‘Administrator’ is inside the Admin Group :confused:


Sorry for the delay here. Its very possible that this behavior is related to this issue . The issue shows up when using a custom account to run the Tentacle service.

Could you try using “Local System” account, at least just to make sure we are in presence of the same issue?



Hi Dalmiro,

your suggestion didn’t solve my problem because i haven’t even set up a running tentacle. I got that error before the tentacle was set up. Nevermind, i just tried it again and it worked. Haven’t changed anything so i can’t even say what was wrong and what the made it work :confused: