Is TeamCity 10 Supported?

Teamcity 10 came out today. I want to upgrade but I’m not sure if the Octopus plugin will continue working on TC 10. Has anyone tried this out?

Hi Matt,
I can confirm that after updating my local TeamCity server to version 10 that the Octopus Deploy plugin appears to still be working correctly without problem. While i wouldn’t think there would have been a problem, it’s certainly never a bad idea to test and confirm suspicions.
Feel free to upgrade your server to the latest version without worrying about your deployment steps!
Let me know if you encounter any problems during the upgrade process.

We’re seeing problems with the Octopus plugin since upgrading

The indexor isn’t indexing the TC nuget feed until the build is complete, which means the deploy step fails because the newly created release in Octopus can’t see the nupkgs created as part of the release until the build completes.

I don’t believe this behavior you are encountering has changed between TeamCity versions since this is how it worked in previous TC versions. As outlined in our TeamCity documentation in the info box delayed package publishing

NuGet packages created from your build won’t appear in the TeamCity NuGet feed until after the build fully completes. If you plan to trigger a deployment during a build, this creates a problem: the package won’t be in the feed until the build is published, so you won’t be able to deploy it.
The solution is to configure a secondary build configuration, and use a snapshot dependency and build trigger in TeamCity to run the deployment build configuration after the first build configuration completes. The video below demonstrates how to do this.

Have any of your build steps changed during this upgrade? Are there any new error messages, warnings or anything else in the logs that have changed between your previous version of TC and the new ones generated by TC 10? If you send some of these though perhaps we can take a closer look and see if anything out of the ordinary is going on. We using the Octopus Deploy TC Plugin with TC 10 in our development workflow and so far have encountered no such issues.

I’m not sure why it ever worked in that case. Perhaps in fixing a defect in 10.0 release has caused this behaviour. The only change we made in upgrading was to change the artefact path from the system default to a folder in the root. The previous behaviour worked well for the path year until Friday when we upgraded.

It seems cumbersome to have to create a new snapshot build for each of our builds.

After teamcity upgrade to 10.0.1, All octopus deployments are failing on the following step:-
Newtonsoft.Json.JsonSerializationException: Error converting value “Canceled” to type ‘Octopus.Client.Model.ActivityStatus’. Path ‘ActivityLog.Children[1].Status’, line 102, position 29. —>

Teamcity is failing the step but Package is created and uploaded successfully as if you try to rerun the deployment again from Octopus it will deploy the package correctly.


This only started after you went from 10 to 10.0.1?

This happened for us moving from 9 to 10.0.1. We had to uncheck the show progress option. I’m not sure what’s changed, but this allowed us to move forward.

HI Adam,

We moved from 9 to 10.0.1. but still unable to fix this error.

Hi @Gigabyte,

On another related thread you said:

Since the Teamcity upgrade to 10.0.1. we are unable to deploy any of the packages. Deploy step fails to deploy because the newly created release in Octopus can't see the nupkgs created as part of the release. I tried putting a sleep using powershell script but still its not working. Can you please guide.

and on this thread:

Teamcity is failing the step but Package is created and uploaded successfully as if you try to rerun the deployment again from Octopus it will deploy the package correctly.

To get started with the troubleshooting, could you please read this post from Rob and send us your build log?

Also please let us know if you are pushing your packages to the Octopus built-in feed, or to TeamCity’s feed.

If you don’t wanna share your logs in this public thread, feel free to do it on this other private thread


Hi Dalmiro,
Thanks for getting back to this quickly. Yes, I have gone through all these posts and none of the solution mentioned worked for me.
We are using TeamCity’s Feed. We have so many projects and trying to change it to Octopus feed is not an easy option for us. but any way I tried to switch to Octopus feed as well but couldn’t succeed in setting it up properly.

In One thread I mentioned that Package is created because when you try to rerun the same failed build from Octopus again it deploy the package correctly. Its only when it is running from teamcity where we have defined steps of (Build, Package and deploy) it failed to deploy.

I have attached the build log on other private thread.

Also I have upgraded the Octopus Server to 3.4.7 just to try if that will resolve my issue but still the same.