Is It Possible to Disable Stdout Processing?

We’re reusing an existing batch script by calling it from a Powershell script in a custom deploy script while deploying a nuget package. Everything works fine, but the batch script produces a lot of output to stdout and it’s taking Octopus too long to process it all. (I can see that the batch file completed 45 minutes ago and Octopus is still processing it’s output. This is very uncomfortable during a deployment.) Is it possible to disable Octopus’ output processing for that script? (Ideally the output would still be in the log, but Octopus just wouldn’t waste time processing it.) If not, I can try to prevent the script writing to stdout, but I’d prefer not to modify it.


Hi Narti,

Thanks for getting in touch! Sorry about the delay in getting back to you here. In this situation we suggest placing a buffer around the commands producing the output.
As you want to keep it in the logs, this will be the only solution.

Enable-OctopusOutputBuffer "Doing some work"
<your command here>

Hope this helps!