InvalidData: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I’m trying the demo of given here with Teamcity and Octopus.

When trying to deploy the RandomQuotes into Devlopment it throws an error saying -

"InvalidData: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020) "

Can you please help me with this.
I have attached the error log as well.
ServerTasks-522.log.txt (18.0 KB)

Hi @jrathod,

First of all, welcome to the Octopus forums!

Thanks for reaching out.

Is it possible there is Antivirus on the tentacle that could be interfering with the process? Can you try disabling the AV temporarily and re-deploying and see if it works?

Please let me know what you think.


Hey Jeremy,

Thanks for replying. I checked with turning off the antivirus but it still doesn’t work.

I even tried to manually deploy the application to IIS on port 8081. But i am getting the same error in IIS.

I’m attaching the screenshot of IIS error as well.

Also, I have my Teamcity setup at port 80 and i don’t know how my sample application also listens to the port 80 and port 8081.

Can this be the problem?

Hey @jrathod,

My apologies, I didn’t the logs correctly. You’re right this looks to be a port issue.

In your deploy to IIS step, when you go down to the bindings, which ports are listed?

Make sure there is only one, and its one thats not in use on the IIS server by other apps.

Please let me know if that works for you.


Thank you so much @jeremy.miller . I changed the port and it worked and I successfully deployed on Dev.

But when I am actually going to the http://localhost:10 to see the demo website. It still throws me an error.

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Do you have any idea regarding this ?

Hey @jrathod,

You’re very welcome.

Would you be able to attach your deployment process json so I can take a look?

To get this go to the Project, then the process section, then click the 3 dots to the right of add step and click download JSON.

If anything is private/secure in there, please feel free to privately message it to me.


Nothing private :smiley: @jeremy.miller.

This is a sample Git code by Octopus, that I am trying out to later do it in my org.

Please find attachment for the process file in JSON format.

Thank yourandom-quotes-process.json|attachment (3.6 KB)random-quotes-process.json (3.6 KB)

Hey @jrathod,

This may be an IIS configuration issue.

Can you take a look at this stackoverflow and see if any of the responses in there resolve the issue for you and let me know?


1 Like

This Stackoverflow link worked like a charm !

Thank you so much, Jeremy!

1 Like

Hi @jrathod,

You’re very welcome! I’m glad to hear we were able to get it going.

I hope you have a great weekend.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.