Installing Tentacle on of our server with get a exception Octopus.Shared.XmlSerializers


Today we had trouble with installing the tentacle on 1 server currently we have installed it on 40 servers without any problem. On 1 specific server we receive the follow exception:

Error: Could not load file or assembly 'Octopus.Shared.XmlSerializers' or one of its dependencies. The system cannot find the file specified.

Full error details are available in the log files.
Error: The previous command returned a non-zero exit code of: 100
Error: The command that failed was: "C:\Program Files\Octopus Deploy\Tentacle\Tentacle.exe" new-certificate --instance "Tentacle" --if-blank
Deleted instance: Tentacle

Even when I try to run the steps manually from a command prompt it give the same error.

I’m using version Octopus Deploy

tentacle_log.txt (3 KB)

Hi Geoffrey,

Thanks for getting in touch!
That error is shown when it cannot create the certificate. This is due to logging in as a temp user profile that does not have permissions to create the certificate.

One work around if you cannot login as a different user is you could log on to one of the other Tentacles that has successfully installed and run the following command:

Tentacle.exe new-certificate --export-file="cert.txt"

This will create the certificate for you to be able to import on the machine it is not installing on.
Then run the second import command on the machine you are having troubles with:

Tentacle.exe import-certificate --from-file="cert.txt"

Let me know how that goes.

I tried logging on with another user and it worked.