Installation Error - Could not find configuration file


We were attempting to setup a new installation of Octopus Deploy on a machine using a copy of an existing database; this is how we replicate our production configuration into a lower environment for testing.

Unfortunately, we did not have the database in place before starting the install. So, a successful install completed creating a fresh/empty Octopus Deploy service.

We realized our mistake and attempted to create a “fresh install” by uninstalling Octopus Deploy from the server and deleting all lingering files from disk.

We then attempted a reinstall from scratch, but ran into an error message that indicated the installer was attempting to using configuration information from the prior install. We do not want it to try to use information from the prior install.

The error message reads:

Configuration file D:\AllContent\Data\Octopus\OctopusServer.config could not be found.

How can we reset the machine so that the installer doesn’t attempt to use any configuration information from a prior install? Or, how do we indicate to the Octopus installer that we do not want it to use any information from the prior install?

Hi Steven,

Thanks for getting in touch! I will need some further information from you to better understand what went wrong here. I can see Octopus is looking for the OctopusServer.config file, which we store the database connection string inside of. This file is created when a new instance is created from the Octopus Manager.

Are you able to confirm that you are creating a new instance on the target server after uninstalling Octopus and removing the files? If you attempt to use the same instance which failed to install due to the missing database, you could expect to see this sort of error.

Here is our documentation on moving the Octopus Server and Database in case you haven’t seen it. It has a lot of helpful information on making sure the transition goes smoothly.

For Octopus to avoid using any information from the previous installation you will need to ensure that you’re creating an new instance through the Octopus Server manager. Pointing that instance to the new database location will create OctopusServer.config and hopefully resolve this issue.

If I’m missing something here and you’re still stuck, you will need to provide some further information on the steps you’re taking to install and configure the Octopus server.

Looking forward to hearing from you and getting to the bottom of this.

Best regards,

Thanks for the info. We were aware of that information, and we have performed this process before successfully.

The difference this time is that we didn’t restore the database first to the new database server. After we discovered our mistake, we decided to completely remove everything Octopus related from the machine to attempt a new clean install.

Your response seemed to indicate that you thought Octopus Manager was still installed; we had removed it before trying again.

When doing the reinstall of Octopus Manager, the initial installation of the Octopus Manager files seemed to complete successfully.

From my memory, the installer finished running and then it started Octopus Manager. Octopus Manager then auto-detected some sort of hidden information on the system which made it believe the old installation was still around and it attempted to load from a configuration file that didn’t exist. (We tried to clean the system, but there must have been hidden configuration information; we would like to get back to a clean server without any Octopus information on it)

As of this writing, Octopus Manager lists as a application in the Start Menu. And, when we attempt to run the application this screen appears and nothing further happens.

Hi Steven,

Thanks for getting back and providing some clarification on your current situation. I apologise for misinterpreting your initial issue. Hopefully the below advice is more relevant and helps get you unblocked.

We have a documentation page with steps on performing a complete manual uninstall of the Octopus Server. It’s possible that among other things, the service for the installation you attempted to remove is still hanging around. This guide should help you clean everything up.

Let me know if you have any lingering issues after the full manual uninstall.

Best Regards,

Thanks! We’ll try it out.

Thanks Steven!

Let me know how it goes. :slight_smile:

Best Regards,

Thank You! That solved our isssue.

1 Like

Hi Steven,

That’s great to hear, thanks for the update! Don’t hesitate to get in touch in the future if you have any questions or run into another issue.

Best Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.