Install Tentacle in polling mode - authentication issue


I’m trying to install a tentacle in polling mode but I’m having trouble authenticating to the octopus server.
I am able to connect to the server but it seems like my credentials are invalid. I’ve tried installing the tentacle on different servers but the response is still the same. The octopus server instance is configured to use windows authentication.
What credentials am I supposed to enter here? I’ve tried most combinations but without any luck so far.
I’ve attached a screenshot with the response from the server. In this example, I use a service account and an API key as password.

Any other suggestions? Thanks in advance.


Hi Gustav,

Thanks for getting in touch! Thanks for attaching the screenshot. From the UI it looks like you might be using a newer version of Tentacle with an older version of Octopus Server. While we do try to maintain backwards compatibility it is not always possible, and we suggest you install Tenacle versions that are as close to your Octopus Server version as possible. You can grab the 3.2.8 Tentacle installer here:

It may not resolve the issue, but as proxy was not supported back in that version and I would like to rule out those potential compatibility issues first.

You can also install a Tentacle via commandline which gives you the option to use an API key instead of the username/password that the UI Wizard requires. Any user with correct permissions should work in this scenario. They need to be able to log into the Octopus server, and also have the ability to create machine records. The user account is only needed to register the machine.

Let me know how you go.


Hi Vanessa,

Thanks for the quick reply. I changed to the 3.2.8 msi package but I still had trouble to provide the correct credentials.

But when I used the command line, I was able to register a tentacle. I used an API key and it worked like a charm. Thank you for sending me in the right direction!


I am also having the same issue described, but with a slightly different log entry in the tentacle output (attached).

The only different beyond the output than what was described is that we are running Octopus 3.5.2 (the tentacle is also 3.5.2); we are not using proxies on either side.

I have attempted to use the command line with an API Key, but I’m still getting an error when trying to register the tentacle. Unfortunately, I can’t see what the error is because the window closes too quickly.


Hi James,

Do you have more than one auth provider enabled after upgrading to 3.5+ ? We believe it might be related to the following issue:
Let me know.


We did not change any of the auth providers, and unless a new one is automatically enabled we should only have Active Directory enabled as an auth provider.



Sorry, wrong conversation