IIS Web Site deployment problem

I am trying to deploy Web Site to IIS 7+ with Octopus deploy.
The problem is that NuGet packages are successfully copied to the Tentacle server but was not deployed to the IIS.
Deployment was processed without any error. Log are clear.
Thanks for help in advance.


Thanks for contacting us. Have you checked our documentation on IIS web site deployments? It has a video that shows how to do fairly easy. Check from 0:35 onwards


If this doesn’t work for you, please send us the deployment raw log and some screenshots of how you configured the deploy step on your deployment process.



Thank for answer.
Yes, I saw video and looks like it does not works for me.
Here is raw log from my Octopus and screenshots you are asked for.

octopus_raw.log (22 KB)


On your deploy step screenshot I can see you have left blank the field “Relative home Directory”. Can you put your app’s root path in there and try again?

Let us know how it goes :slight_smile:


Hi, I’ve tried out “” for root and “content”.
All the same - deployment package appears in C:\Octopus\Applications\Development but not in Web Site root.
By the way, i tried to enable “Custom installation directory” and added path from c:\ but package was not deployed as well.


“Relative home directory”(RHD) is relative to the value you inserted on “Custom Installation Directory”(CID). If on CID you put C:\Deploy\MyApp and on RHD you put nothing, the package will be deployed to C:\Deploy\MyApp and the IIS Web site will be reconfigured to point to the root of CID, which is also C:\Deploy\MyApp.

TLDDR: on CID put the exact path where you want your app to be deployed and your IIS web site to be pointing to. Leave RHD blank. Make sure you check the box “Force deployment of packages that are already installed” to force the deployment

Check the screenshots i’ve attached for better reference. IISpre.jpg shows the path value before the deployment/reconfiguration, IISPost.jpg shows the value after the deployment.





Hi, thanks for help, but still nothing.
Made all following instructions (screenshot attached).
And I did not found “Force deployment of packages that are already installed” checkmark.


No worries, we’re here to help! Lets see if we can figure this one out, we’re very close :slight_smile:

Could you please set the variables OctopusPrintEvaluatedVariables and OctopusPrintVariables as shown on the link below and then send us back the raw log. Make sure your deployment process includes the IIS step you show me on your last screenshot!




Hi, thanks for help.
Here is raw log after setting variable and screenshots that should confirm that variables are set properly.

ServerTasks-937.log.txt (17 KB)


Unfortunatelly, we cannot see the variables we were expecting after enabling OctopusPrintEvaluatedVariables and OctopusPrintVariables. I noticed on the logs you sent us (last week and today) that you are re-deploying the same release 14.12.0 over and over again. After you enable those 2 variables, you need to create a new release to be able to see the changes. Since we do snapshots of the variables on each release, your changes wont take effect until you create a new one.

Please try to create a new release after setting those variables to true and send us back the logs :slight_smile:



Hi again.
After creating new Release it looks line new settings has been applyed but I have got another error. Log is attached.

ServerTasks-945.log.txt (75 KB)


This error is caused from having a website already listening on port 80. The error itself is a little generic but it is from IIS.



I have a similar problem with deploying website.

I chose a Physical path outside of Tentacles app path.

As a result I can see a successful release log but without copying files to the right place. All other steps are correct:

  1. Website have been created right (it points to the right place outside of Tentacles)
  2. App pool and other settings are correct
  3. I can see a new deploy version with all files in Tentacles app folder

Can you help me to understand how those files can be copied to the right folder?

Closing old thread and splitting this conversation into a new one: http://help.octopusdeploy.com/discussions/problems/48487-iis-web-site-deployment-problem