IIS binding is not working

Hi Support,

I have .Net Web Application is deploying to one of environment (i.e Staging and Production)

I have configured IIS Binding as like below

Protocol: http
Port: 85
IP Address: *
Host:

So, i used to access mt website using <IP_address>:85

Now i would like to access my website using some domain name(exp: cb.tyndaris.com). For that Do i need to configure anything in IIS Tool, before enabling IIS Binding in Octopus server.

I saw in one of tutorial video like below,

Protocol: http
Port: 80
IP Address: *
Host: #{Octopus.Machine.Name}.octofx.org

I have tried like above, but still, i am not able to access my website with domain.

Do you want to give valid host, if so the above host is valid. with http://cbn.tyndap.com/ website i can able to access IIS server home page.

Could you please help me how to configure this.?

Thanks,
Naresh Ch

Hi Naresh,

Thanks for getting in touch and taking the time to work through this problem with our documentation. It looks to me like your IIS configuration is correct, but I can see from your screenshot that IIS has not been updated for some reason.

Here are some questions/steps you can answer/follow that will help diagnose what is going wrong:

  1. Did you create a new Release of this Project after you updated the IIS settings in your Deployment Process? If not, the new IIS settings won’t have been applied because Octopus takes a “snapshot” of your process when a release is created. Read more about snapshots in this blog post. To work around this, simply create a new release of the project and deploy it
  2. If #1 doesn’t help, can you please send me the raw log from the deployment task so I can help you further?

Hope that helps!
Mike

Hi Mike,

Thanks for quick response.

Finally, i am able to access my website with hostname, which i given in IIS binding.

Thanks,
Naresh Ch

Hi Naresh,

That’s great news.

Happy Deployments!
Mike