I can not download artifacts after upgrade

I recently Upgrade Octopus server to 2022.2.6895.
After that i can list the artifacts: with
/api/Spaces-1/artifacts

Items": [
    {
      "Id": "Artifacts-2420545",
      "SpaceId": "Spaces-1",
      "Filename": "DeployTo_RISSQLW1_center1_ad_local_Reporting_20220708092954_DeployScript.sql",
      "Source": null,
      "ServerTaskId": "ServerTasks-264790",
      "Created": "2022-07-08T09:33:03.813+00:00",
      "LogCorrelationId": "ServerTasks-264790_74DZUST93R/08d77182f4d9440fbf516970da9d3de6/4ecbe2e67203473eab8c06a61c312f48",
      "Links": {
        "Self": "/api/Spaces-1/artifacts/Artifacts-2420545",
        "Content": "/api/Spaces-1/artifacts/Artifacts-2420545/content"
      }
    },

But i cant download:
/api/Spaces-1/artifacts/Artifacts-2420545/content

I dont get an error, just endless timeout.

Thanks for reaching out Andres. I’m sorry that you are experiencing this issue.

So I can determine if this issue happened to the artifacts during the upgrade, or if it is a problem with all artifacts on the version 2022.2.6895, can you create a new artifact and check the Content link?

Did you move any folders during the upgrade or was everything left as it was?

Regards,

Hi,
Interesting i reply to the email, but the message was cut.

So this is the scenario:

  1. I tried a new release, and still i cant not download artifacts.
  2. I only ran the upgrade process and the /octopus/artifacts folder is still there.
  3. it is complicated to debug, the brownser doest thrown any error, just keep waiting

IM not sure if it could be a permission or configuration issue. But as i mentioned, nothing else has been changed.

Hi Andres,

Thanks for the extra information. We can definitely progress from here.
Because the new artifacts are still not accessible, there is definitely a chance that we may have a permissions issue on our hands.

Can you please provide the following information:

If you navigate to the artifacts folder, can you see new artifacts being created?

Generally Octopus will try to write to the artifacts folder using the Octopus Deploy Service user.
What is the user that Octopus Server runs under?
Is it System or is it a specific account?
Does that account have read/write permissions to the artifacts folder?

Would you be able to provide a HAR file when you attempt to download an artifact? Open up the Developer console, create the release and then click on the artifact, before exporting the HAR file. This should provide some good information for us to determine what the issue is.

You can securely upload your files to this location.

Regards,

Hi Dave,

  1. I can see the new artifacts in the directory
  2. Octopus service account can create the documents and read. I checked that new artifacts are being created.
  3. The folder is close to 3 million artifacts. Shouldnt we move those artifacts to an external tool, like Jfrog Artifactory?

I just upload the HAR file, but downloading the file just show „pending“ state.

Hi Dave,

Hi @andres.colodrero,

There has been an investigation into some very slow artifact retrieval times (sometimes resulting in handing processes) in the latest versions of Octopus. I think this is likely the issue that you are running into.

A Pull Request with some code amendments that should vastly improve artifact retrieval times was raised earlier today. The Pull Request needs to go through testing and roll-out to the early adopters before it is available to everyone else. This means, unfortunately, we are likely a few weeks away from having that release made available to our GA release stream.

Here’s a screenshot of the results that one of the engineers achieved when testing this change:

If you subscribe to this issue you will be informed in the comments on what version of Octopus Deploy the issue will be fixed in. Once it appears in the comments it can still be a few days before the version is available on the downloads page.

In the meantime, you might have to access these artifacts directly via the artifacts folder.

As for a JFrog feed, this could potentially help, but I would say that if you can hold out for a couple of weeks, you would save the effort of changing your infrastructure and introducing another component like artifactory.

Please let me know if you have any more questions.

Regards,

Dane

Excellent!
thanks for the answer, i will keep informed.

1 Like

HI @dane.falvo JUst to confirm that after upgrade to 2022.2.7336, download of artifacts works perfect.

we also faced some issues with SQL server, where all connections coming from “GetArtifactsByID” where never closed and caused tempdb problems.

1 Like

That’s excellent news Andres!

Thanks for letting me know.

Regards,

Dane