How to get updated version of "Deploy to IIS" step template with SNI support

usability
(J F) #1

I am currently on an older version of Octopus Deploy (v 4.1.5) and use the “Deploy to IIS” step template in a deployment process.

I have a need to now start setting the SNI “Require Server Name Indicator” setting in IIS when creating certain bindings for websites during deployment. The version of Octopus I am running does not have this as a configurable setting in the step template. I’ve done some research and I see that at some point this was added as a configurable setting to the step template.

If I upgrade my instance of Octopus will it come with the latest “Deploy to IIS” step templates that contain the SNI setting? Any idea what version of Octopus included this new SNI setting in the template, I was unable to find any reference too it in a history of release notes.

Heres a photo someone posted on a forum back in 2017 showing the feature as part of the Octopus Deploy IIS Deploy template:

#3

Hi @jer.fer

Thanks for getting in touch, and sorry that it’s taken a couple of days for me to respond.

I’ve confirmed that the latest version of Octopus has the SNI option that you are seeing, however after checking with the developers this has been included in Octopus since a very early version (2.6 I believe) so I’m a little confused as to why this option isn’t available to you.

Regardless, I would recommend upgrading to an LTS release of Octopus (either 2018.10.x, 2019.3.x or 2019.6.x). The 2018 LTS release is no longer in maintenance, however it is the last LTS upgrade before the introduction of spaces so is still quite popular. I would recommend upgrading to 2019.6.x if possible as that will give you the longest support window. A direct upgrade is possible here, and we have documentation available that walks you through the entire process.

Please let me know if you have any further questions,

Regards,
Alex

(J F) #4

Hi Alex thank you for your response and for looking into this.

After you mentioned that this feature has been available for some time I realized the issue was I had “HTTP” set as the protocol and the Octo “Add Binding” modal is smart enough to change when “HTTPS” is shown. Once “HTTPS” is selected I get the “SNI” options as I expected.

Thanks!

#5

Hi @jer.fer

Great news, glad that you worked that one out :).

Please let me know if there is anything else we can help with.

Regards,
Alex