How to enable SNI on IIS HTTPS binding?

We’re using Octopus Deploy and its “IIS web site and application pool” process feature to deploy our ASP.NET MVC app to IIS. It’s working great.

Now, we would like to enable SNI for the HTTPS binding. Octopus Deploy doesn’t seem to provide a built-in checkbox for this. How could we customize the Octopus Deploy’s IIS deployment so that the SNI is enabled automatically?

If it makes things easier, it’s OK for us if Octopus Deploy automatically enables SNI for all the HTTPS bindings, we don’t need a setting for it.

(This is a repost from SO:

Thanks Mikael, I’ve replied on StackOverflow


Looks like solution to this problem is not figured out yet. Even in Stack Overflow there aren’t any specific solutions.

Hi @Dattha,

Thanks for getting in touch. You are correct, a solution for this still hasn’t been implemented.

Could you please log a feature request in Uservoice to add SNI support in IIS? If enough users vote for it, we will definitely consider adding support to it.

For the time being I’d recommend you to enable SNI for your website after the deployment in a dedicated step using Powershell.

Best regards,

I have voted for the feature. However, a temporary solution can be achived through below link.