Helm failed to download the chart

Hi there,

I’m trying to deploy a Helm chart using the “Kubernetes > Upgrade a Helm Chart” step. I’ve configured the step to reference a package from an External (Helm Feed type). It’s works well when I’m testing by “Save and Test” option, but when the step with connecting to Helm Chart repository is started from Runbook i faild with message: “The step failed: Activity failed with error ‘Helm failed to download the chart (Status Code 404). Reason: $Not Found’

My Helm Chart repository is located in private Github repository. I’m wondering wheather the private Github repo might be soruce of issue. But I want to use non public Helm chart.

What should I do now?

Thank you in advance.

Good afternoon Kurtz,

Thanks for reaching out and I’m sorry to hear you are having issues with the Helm charts step.

Are we able to create a support user on your cloud instance please so we can take a look and see if we can spot anything obvious?

I look forward to hearing from you but in the meantime please reach out if you need anything else.

Kind Regards,

Clare Martin

Yes, please :slight_smile:

I am getting the same error from an on-prem Octopus instance when trying to access a helm repo hosted by gitlab per the documentation at Helm charts in the Package Registry | GitLab. When I add the External Feed and test I can pull back all the chart names. When the Upgrade a Helm Chart step runs I get the error - The step failed: Activity failed with error ‘Helm failed to download the chart (Status Code 404). Reason: $Not Found’.

Hi @kurtz and @max.zimmerman,

Just stepping in here while Clare is offline.

We’ve seen what looks like this exact issue before, which was due to a missing “/” at the end of the chart repo URL. Octopus uses the specified URL exactly, where I believe the Helm client does some manipulation of the URL to add the trailing “/” if it’s missing. Does adding the trailing “/” in the URL in Octopus (i.e. https://your.repo/chartrepo/) get it working as expected?

I’m hoping that helps unblock you quickly, if that does not work please let us know.

Regards,
Garrett

1 Like

@garrett.dass - Thanks. Now I have no errors with Helm chart repository :slight_smile:

1 Like