Files missing from .NuGet package

I’m simply using “nuget.exe pack Sites.nuspec” to create my NuGet package, then using Octopus to deploy.

I’ve noticed however that while the source dir had 8244 files, the destination has 8140 files.
It appears NuGet is excluding files that start with (.) a period.

This may be by design to not include source control files, etc… but I want to override this behavior. My only other solution would be to create a .zip file which I put in the nuget package, but thats lame. I can’t find any options to the pack command that lets my include, exclude any files.

Any ideas?

Looks like I need to provide: -NoDefaultExcludes to the pack command…

Hi Gavin, thanks for sharing your solution!