File exclusions for purge are case sensitive?

I’ve noticed that when using the custom install directory, the list of file/folder patterns to exclude from the purge is case sensitive.

I am deploying a .Net application to windows server 2012R2

I have this as a filename to exclude
somefolder\MYAPP.exe.config

On my deployment target that config file had the same name, but a different casing.
somefolder\MyApp.exe.config
It was purged.

It would be helpful if this was documented in the custom install step somewhere.

Other thoughts:
A chekcbox or similar so I could opt-out of case sensitivity.
Since the Windows O/S is not a case sensitive filesystem, maybe there’s something that could be handled depending on the deployment target?

Hey Phil,

First of all welcome to the Octopus Forums.

Thanks for reaching out. Sorry to hear your file got deleted in error.

Would you be able to send me a screenshot of the step in question with all the settings so I can attempt to reproduce the error on my end. If it needs to be private feel free to direct message the screenshots to me.

Also, which version of Octopus Server are you currently on?

Thanks,
Jeremy

Using Octo 2020.4.11

Sent private DM w/screencap

Thanks

As a follow up I should correct my comment about windows O/S not having a case sensitive file system.

It looks like certain versions of Windows can be case sensitive depending on the specific edition and the settings for the specific folder.

The NTFS file system is case sensitive, but the case sensitivity is disabled in windows by default.

Hey Phil,

Thanks for the info. I was able to reproduce this on my end on latest so I’m going to pass this along to our engineers along with the issue.

Please let me know if you have any questions or concerns in the meantime. Here is the github issue that you can subscribe to. https://github.com/OctopusDeploy/Issues/issues/6686

Thanks,
Jeremy

Hi,

I just wanted to reach out and let you know that we have flagged this as an issue, but at this point we do not have capacity to assign an engineer to resolve the issue. We’ll keep the issue open, but unfortunately we can not provide any guidance as to when it will be resolved. I’m sorry for the inconvenience, and we do appreciate that you took the time to report the issue.

Regards Matt

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.