Error from Octopus server (HTTP 404 NotFound)

Hi when trying to push a package to the octupus server from team services i get the following error.(see attached). I am wondering am i using the wrong url for the server i have tried http://localhost/ and http://localhost:80/ . any idea of what the correct url to the server should be.


Thanks for getting in touch! The url is the same url you use to access the web UI on. Unless the Octopus server is on the same server as team services, localhost won’t work.

Hope that helps!

Robert W

hi to open the web interface i use http://localhost/Octopus/app#/ is this the correct url ?


http://localhost/Octopus is the correct url. I should have mentioned you can see the urls that are configured in the Octopus Server Manager (available on the start menu).

Robert W

i am still getting the same issue i am giving it http://localhost/Octopus url and the api key in the service endpoint. is there anything else i could be doing wrong


Just to confirm, you are logged into the same machine as the team services agent is running on and octopus deploy server? ie everything is on the same machine/server?

What version of Octopus are you using?

What happens if you issue the command from the command line?

What version of the plugin are you using?

Have you tried using the public hostname or ipaddress of the octopus server instead?