Error during discovering tentacle

I have a problem I cannot find anything about in the support forum. I Use Octopus Tentacle and Octopus deploy with the same version. Trying to discover a tentacle I get:

NL: “Verificatie is mislukt omdat de andere partij de transportstroom heeft gesloten.”
EN: “Authentication failed because the remote party has closed the transport stream.”

I installed a tentacle for my test machine S31 and deployed succesfully to it.
Then I installed a tentacle for a acceptance machine S18, but this machine though installed without problems, can NOT
be discovered by the octopus server.
Viewing and comparing the logs of the two machines I discovered that the second machine starts with a warning about a private key before it returns an error.
I tried the latest version of Octopus Tentacle but that does not change the error message and log.

If I let the service run under my own user name it will be discovered, but that is not how it is supposed to work.

What is wrong here? What should I check?

OctopusTentacleS18Clean.txt : OK install log,
OctopusTentacleS18Clean.txt : failing tentacle log

OctopusTentacleS18Clean.txt (4 KB)

OctopusTentacleS31Clean.txt (2 KB)

Hi Oleg, thanks for getting in touch.

It is possible the Tentacle service is running without enough privileges on the local machine - is it using a custom account, or Local System?

Some descriptions of this error (e.g. suggest key size as a possible cause - did you upgrade the machine from Octopus 1.6 (which may use a smaller key) or is it a fresh 2.0 Tentacle install?


The error appeared after a fresh install of, no update, this was the first tentacle :wink:
We tried a newer version as well, but that had the same issue.
Out of the box the tentacle runs under local system account, but that one is not working.
As a work-around it now is running under the user name of the one who installed it, as that does work.

But on the other machines (for example S31) the same kind of install did work out of the box.