Error after switch to configure as code

I have exists project with process. I cloned project for testing configure as code feature.
But after i setup VCS (git) and confirm operation i receive error “The resource you requested was not found”.
Same error occurred on each page, depended on VCS: Process, Settings, Variables-> Project, Variables-> All, Variables-> Preview.

In my repository i can see folder .octopus with following files:

  • deployment_process.ocl
  • deployment_settings.ocl
  • schema_version.ocl
  • variables.ocl

deployment_process.ocl contains file with process describe (all step presented)
variables.ocl contains variables from project

but then i try to open project page i see following errors:

  • /api/Spaces-1/projects/Projects-3/refs%2Fheads%2Fdevelop/summary : 404, The resource you requested was not found.
  • /api/Spaces-1/projects/Projects-3/refs%2fheads%2fdevelop/deploymentprocesses : 404, The resource you requested was not found.
  • api/telemetry/process : ERR_CERT_COMMON_NAME_INVALID

Octopus installed in private network and does not use SSL
My Octopus Server version is: 2022.3.10483

this is data from octopus server log:

2022-09-15 14:47:38.6847   7128     98 ERROR  Error getting summary for { Id: "Projects-3", SpaceId: "Spaces-1", VariableSetId: "variableset-Projects-3", DeploymentProcessId: "deploymentprocess-Projects-3", ClonedFromProjectId: "Projects-2", DiscreteChannelRelease: False, IncludedLibraryVariableSetIds: [], DefaultToSkipIfAlreadyInstalled: False, TenantedDeploymentMode: "Untenanted", DefaultGuidedFailureMode: "EnvironmentDefault", VersioningStrategy: null, ReleaseCreationStrategy: { ChannelId: null, ReleaseCreationPackage: null, ReleaseCreationPackageStepId: null }, Templates: [], AutoDeployReleaseOverrides: [], ReleaseNotesTemplate: null, DeploymentChangesTemplate: null, Icon: null, ExtensionSettings: [], Name: "Test", Slug: "test", Description: "", IsDisabled: False, ProjectGroupId: "ProjectGroups-1", LifecycleId: "Lifecycles-1", AutoCreateRelease: False, IsVersionControlled: True, PersistenceSettings: { Type: "VersionControlled", Url: "https://<redacted>", Credentials: { Type: "UsernamePassword", Username: "<redacted>", Password: { HasValue: True, NewValue: null, Hint: null } }, DefaultBranch: "develop", BasePath: ".octopus", ProtectedBranchNamePatterns: [], ConversionState: { VariablesAreInGit: True } }, ProjectConnectivityPolicy: { SkipMachineBehavior: "None", TargetRoles: [], AllowDeploymentsToNoTargets: False, ExcludeUnhealthyTargets: False }, Links: { Self: "/api/Spaces-1/projects/Projects-3/{gitRef}", Variables: "/api/Spaces-1/projects/Projects-3/{gitRef}/variables", Releases: "/api/Spaces-1/projects/Projects-3/releases{/version}{?skip,take,searchByVersion}", Channels: "/api/Spaces-1/projects/Projects-3/channels{/id}{?skip,take,partialName}", Triggers: "/api/Spaces-1/projects/Projects-3/triggers{?skip,take,partialName,triggerActionType,triggerActionCategory,runbooks}", ScheduledTriggers: "/api/Spaces-1/projects/Projects-3/triggers/scheduled{?skip,take,partialName,ids}", OrderChannels: "/api/Spaces-1/projects/Projects-3/channels/order", Progression: "/api/Spaces-1/projects/Projects-3/progression{?aggregate}", RunbookTaskRunDashboardItemsTemplate: "/api/Spaces-1/progression/runbooks/taskRuns{?skip,take,ids,projectIds,runbookIds,environmentIds,tenantIds,taskIds}", DeploymentProcess: "/api/Spaces-1/projects/Projects-3/{gitRef}/deploymentprocesses", DeploymentSettings: "/api/Spaces-1/projects/Projects-3/{gitRef}/deploymentsettings", Web: "/app#/Spaces-1/projects/Projects-3", Logo: "/api/Spaces-1/projects/Projects-3/logo?cb=2022.3.10437", Metadata: "/api/Spaces-1/projects/Projects-3/metadata", Runbooks: "/api/Spaces-1/projects/Projects-3/runbooks{?skip,take,partialName}", RunbookSnapshots: "/api/Spaces-1/projects/Projects-3/runbookSnapshots{/name}{?skip,take,searchByName}", Summary: "/api/Spaces-1/projects/Projects-3/{gitRef}/summary", GitConnectionTest: "/api/Spaces-1/projects/Projects-3/git/connectivity-test", InsightsMetrics: "/api/Spaces-1/projects/Projects-3/insights/metrics{?channelId,environmentId,tenantId,tenantFilter,timeRange,granularity,timeZone}", Branches: "/api/Spaces-1/projects/Projects-3/git/branches{/name}{?skip,take,searchByName,refresh}", Tags: "/api/Spaces-1/projects/Projects-3/git/tags{/name}{?skip,take,searchByName,refresh}", Commits: "/api/Spaces-1/projects/Projects-3/git/commits{/hash}{?skip,take,refresh}", RepositoryModified: "/api/Spaces-1/projects/Projects-3/git/modified", ValidateGitRef: "/api/Spaces-1/projects/Projects-3/git/validate", SensitiveVariables: "/api/Spaces-1/projects/Projects-3/variables" } }
    at Object.error (http://<redacted>/app-main.42523ad32acbaf374d61.hashedasset.js:2:2218995)
    at Object.onProjectUpdated (http://<redacted>/app-main.42523ad32acbaf374d61.hashedasset.js:1:2919960)
    at async http://<redacted>/app-main.42523ad32acbaf374d61.hashedasset.js:1:2922274

Hi @anatoly.kryzhanovsky1,

Thanks for reaching out, and welcome to the Octopus community! I’m sorry that you’re having issues configuring version control for your project. I would like to get some more information to help us find a resolution.

Could you send us a full copy of your Octopus server log? I will send you a secure upload link you can use for that.

Based on those URL’s it looks like you may have specified develop as the Default Branch Name in the VCS settings; is that correct? Does that branch name match what you see on the repo side?

The last thing I’ll have you try is to clear the local Git cache on your Octopus instance. You can browse to Configuration > Git and hit the CLEAR LOCAL CACHE button. When doing this, could you verify that the Octopus server folders are deleted? We’ve had reports of the folders being kept in use, in which case you can manually delete them before clearing the cache again in the UI. The cache folders are located within the Octopus home directory on the server (i.e., C:\Octopus\Git).

I look forward to hearing back, and please let me know if you have any other questions for us.


thanks for quick answer

  • i uploaded full log file via your link
  • yes, my default branch is develop and that is equal to branch name in VCS
  • after i press CLEAR LOCAL CACHE button folder still exists, i try to delete it manually but os talk that there are files in use. so i stop octopus, delete file and start it again
    but i still receive same error

Hey @anatoly.kryzhanovsky1,

Just jumping in for Dan who will be online soon as part of our US based team.

Thank you for sending us the logs. I can see Octopus is actually connecting to the repository successfully (some bits redacted for security reasons):

2022-09-15 16:08:09.3239   7128    209  INFO  git-op on "xxxxxxxxx" root: Fetching Repository "xxx/anatoly.kryzhanovsky/test/" "succeeded" after 1064ms.
2022-09-15 16:08:09.3239   7128    209  INFO  git-op on "xxxxxxxx". Synchronising branches "succeeded" after 002ms.
2022-09-15 16:08:09.3239   7128    209  INFO  git-op on "xxxx" worktree: Reset hard "completed" in 74.4 ms
2022-09-15 16:08:09.3239   7128    209  INFO  Git Repository Worktree "xxxx". Size (kb): 58.53
2022-09-15 16:08:09.3239   7128    209  INFO  TinyTypeConversionStrategyProvider: Loading lookups "succeeded" after 050ms.
2022-09-15 16:08:09.3239   7128    209  INFO  TinyTypeConversionStrategyProvider: loaded 19 documents
2022-09-15 16:08:09.3239   7128    209  INFO  Request took 1275ms

But I can then see errors for Project3:

2022-09-15 16:08:09.3239 7128 209 ERROR Error getting summary for { Id: "Projects-3", SpaceId: "Spaces-1", VariableSetId: "variableset-Projects-3", DeploymentProcessId: "deploymentprocess-Projects-3", ClonedFromProjectId: "Projects-2", Disc

I can also see the error you posted up in your initial comment too.

I am going to put this to our engineers as they will have a better understanding of what those errors mean.

I will get back to you once we have further information. It would be useful to get a HAR file starting from you clicking on the project itself and then navigating through some of the project pages if you can. You can use the same link Dan gave you to upload it.

Can you let us know once that has been uploaded and I will get that sent to the engineers too, we will keep you posted on any updates.

Kind Regards,


Hi, clare.martin. Thanks for answer!
i created har file and upload it via provided link

1 Like

Hey @anatoly.kryzhanovsky1,

Great thank you for letting me know I will pass that onto our engineers.

We will update you when we have some information.

Kind Regards,


Hey @anatoly.kryzhanovsky1,

Sorry for the lack of communication on this one but our engineers have an idea what this might be.

Are you running Octopus behind IIS at all?

If so, the workaround in this issue might resolve this. Are you able to take a look at the issue and see if it matches what you are seeing.

If so are you able to implement the workaround and see if that fixes the issue for you?

Let me know if it doesn’t and I will take that back to the engineers.

Kind Regards,


Hello again, thanks for answer
we have reverse proxy before Octopus Server, but not IIS - we use nginx. so may be there are the same thing? i will investigate that way today.

Hey @anatoly.kryzhanovsky1,

I don’t think this is related to that GitHub issue then as that is specifically for IIS, the workaround has you going into the IIS settings to input some things in there and its IIS that is messing up the URL when its trying to get to the CaC repo.

Let me get back to the engineer first and see if he has any other suggestions, you might not even have IIS installed on your server in order to implement the workaround and I would rather you not change settings that are not required.

I will let you know what our engineer says,

Kind Regards,


so, i think that i found problem.
in nginx there is process called normalization. i remove trailing slash after rewrite instruction and now it seems to be worked!
i can load process from repository, can see variables and other page that early not worked

Hey @anatoly.kryzhanovsky1,

Oh fantastic! Thank you for letting us know that fixed the issue, it will really help other customers who check on here and are seeing the same thing.

I will update our engineers too as that’s a good thing to note.

Thank you for your patience whilst we went through this and thank you for trying different things to get to a resolution!

Kind Regards and Happy Deployments!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.