Enable "Script" Feature Permission for IIS Web Application Deployment

I’m running Octopus 3.12.2 and trying to use the “Deploy an IIS Web Site” deployment step. However, the site that gets created does not have the “Script” Feature Permission enabled under Handler Mappings. How do I tell Octopus to enable this?

Hi John,

Thanks for getting in touch! While there is nothing in Octopus itself for modifying this setting, I have just created a script that will let you do so in PowerShell. It can be added to your deployment process.

Let me know what you think.

Best regards,