Downloading package on the Tentacle failed


Firstly - Octopus is an excellent tool and a great help to me.

I have a run in to an issue since upgrade to I have a number of servers that the tentacle is installed on. I have an web application that I deploy to the servers. I deploy to one server and it works fine, I deploy to 2 others, I run in to an error. That error being:

2013-05-26 19:34:22 ERROR Unable to download package: The remote name could not be resolved: ‘XXXXX’ System.Net.WebException: The remote name could not be resolved: ‘XXXXX’

XXXXX is a team city server where the packages get deployed from.

I have other applications that I deploy from the same source to this destination and it works fine. What is further difficult to understand is that this package deploys without issue to another server. And also, I have recreated multiple packages for this application as same error is occurring.

Any ideas what the issue may be here? What should I be looking for?

Hi Niall,

It sounds like you are using the new tentacle download feature in which the Tentacle servers connect directly to TeamCity to fetch the package. By the sounds of it, one server is able to resolve the TeamCity server address, while the other servers are not. RDPing into the Tentacles that fail and trying to browse to the TeamCity server should allow you to reproduce the problem.

Alternatively you could change the package step settings to have Octopus download the package from NuGet and then upload it to your Tentacles.

Hope that helps,


Great - thanks for your help. That was it.