Deployment target add by ssh over the proxy

Hi Team,

We are trying to add the deployment target (unix box) over the proxy from the octopus deploy app server. Due to this , We have installed a squid proxy at the proxy server over port 8080. From the octopus app server to the proxy server the network connectivity is working fine over port 8080 and also from the proxy server to the respective deployment target server(unix box) network connectivity working fine over the ssh port i.e. 22 . Now, during the deployment target addition with the option connect through this deployment target through the proxy getting mentioned error.

Could advise over here as I am getting error though all network connectivity is in placed. Also please advise if anything extra need to be configure in proxy server for octopus to connect the deployment server over proxy.

Hi @om.joysaha!

Thanks for reaching out, and sorry to hear that you’re having issues getting your SSH targets. Assuming your Squid proxy is configured correctly, you should just be able to configure a machine proxy in Octopus:

Once that’s configured, you should just have to specify it when setting up your deployment target like so:

I hope this helps!

Thanks Justin for your response over here. We have followed the same steps which you have provided in the mentioned screenshot to add the machine proxies and deployment target add through that proxy. But getting the error which I have mentioned in the earlier post.

Could you please help us for the squid proxy configuration if anything extra need to be configure during proxy setup at proxy server like allow , proxy pass or any additional settings etc so that We can sure that our squid proxy configuration is ok .
Please advise.

Off the top of my head, you should just need to allow port 22 to be proxied by adding it to the SSL_ports and Saft_ports acls in your config.

acl SSL_ports port 22


acl Safe_ports port 22

Hi Justin,

Thanks for all your help over here. It is working as expected.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.