Deploy to Linux Azure web app with old Octopus version

Hello,

We’re using an old version of Octopus for our deployments 3.15.8. from July 2017.

Till now we didn’t have any problem with it. Now we’re trying to deploy an app to an Azure linux web app and we’re getting the following error

“: Could not connect to the remote computer (”*********-webapp.scm.azurewebsites.net"). On the remote computer, make sure that Web Deploy is installed and that the required process (“Web Management Service”) is started. "

Investigating the error we’ve seen several threads with similars error which were solved setting the flag WEBSITE_WEBDEPLOY_USE_SCM to false. But setting it to false we got the same error during the deployment. It seems Octopus is ignoring this flag.

Looking to other similar issue we found this request to support Azure linux deploy from Octopus Support Azure WebApps on Linux · Issue #5012 · OctopusDeploy/Issues · GitHub from 2018. Could be that our Octopus version from 2017 doesn’t support deploy to Azure Linux Web apps? or setting WEBSITE_WEBDEPLOY_USE_SCM to false just also it should work?

Thanks

Hi @cpmarc,

Thanks for getting in touch!

We have seen this kind of issue occur more recently over the past year or so. It seems that Microsoft is deprecating the web deploy mechanisms we used within this step for deploying to Linux web app targets.

We have recently added a new Azure step (“Deploy an Azure App Service”) that uses the newer zip deploy method and will work fine for Linux web apps.

At this point, your options would be to either upgrade to our latest version or create your own step template script for deploying your Azure webapp.

Regards,
Paul