Deploy to Azure PaaS


We have been attempting to deploy to Azure PaaS using Octopus. Currently we can deploy successfully, the website is accessible, but the subnet that we include in the cscfg file is not being setup. If I deploy the same cscfg using visual studio manually the subnet is setup. The example xml is attached, any help would be appreciated.

exampleXML.txt (781 Bytes)

Hi Marcello,

Thanks for getting in touch. Have you tried using the Variable Substitution feature already?

This way you can have the following value on the cscfg file

   <Subnet name="#{MySubnet}"/>

Then create a variable of name MySubnet and value MySubnetName

And after the deployment, the cscfg file will look like this

    <Subnet name="MySubnetName"/>

If you already tried this and it didnt work for you, Please send me the following info so i can see what happened

  1. Enable the debugging variables on your project, create a NEW release (so the variables take effect), deploy it and send me the raw log

  2. Send me the content of your cscfg file prior to the deployment (just like it is on the NuGet package).

  3. Send me a screenshot of your deployment step. Make sure all the fields can be seen on it.